Bug 320 - tar dumps wrong user/group values for users not in /etc/passwd
Summary: tar dumps wrong user/group values for users not in /etc/passwd
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tar (Show other bugs)
(Show other bugs)
Version: 5.2
Hardware: All Linux
high
medium
Target Milestone: ---
Assignee: Bernhard Rosenkraenzer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-06 23:25 UTC by J|rgen Christoffel
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-03-08 18:02:33 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description J|rgen Christoffel 1998-12-06 23:25:05 UTC
when tar dumps and later extracts files without an owner
listed in /etc/passwd it erroneously uses the owner/group of
the last file which had a valid owner. I had to reconfigure
my boot disk and thus dumped its contents with tar,
installed a fresh Redhat 5.2 and restored the data while the
virgin passwd file from the install was in place.

All user files suddenly belong to root because no user
entries exist in /etc/passwd during the restore.

A work around is to use tar's -o option to create old style
archives. Existing tar files may be extraced with the
undocumented option --numeric_owner. The real solution is to
patch the caching in names.c (sent via separate mail).

Comment 1 Mike Maher 1999-03-08 18:02:59 UTC
added patch and rebuilt for next release.
currently in rawhide.


Note You need to log in before you can comment on or make changes to this bug.