Bug 320031 - Can't load Areca driver, arcmsr, onto FC6 through driver disk
Can't load Areca driver, arcmsr, onto FC6 through driver disk
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
6
i386 Linux
low Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
: HardwareEnablement
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 08:29 EDT by nickcheng
Modified: 2007-11-30 17:12 EST (History)
4 users (show)

See Also:
Fixed In Version: F-7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-05 11:46:09 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description nickcheng 2007-10-05 08:29:59 EDT
Description of problem:
Can't load Areca driver, arcmsr, through driver disk

Version-Release number of selected component (if applicable):
i386

Steps to Reproduce:
1. Start the normal installation procedure with Fedora Core 6 Installation Disk1
2. key "linux dd" after promt boot:
3. select "Yes" while dialog asks "Do you have a driver disk"
4. choose the floppy disk, fd1, which has the device driver image
5. press "OK" on the Insert Driver Disk" dialog block
6. after the dialog block shows "Do you wish to load any more driver disks?",
press "Ctl+Alt+F3". Then ,you can see "modules to insert ....... arcmsr ....
sata_nv" and "load module set done", but it will not show the Areca driver
information after press"Ctl+Alt+F4". 
7. go through the process till it asks "Select the drives to use for this
installation"
8. the menu will show anything but Areca volume disks

Additional Information: 
It will not happen on x86_64 installation process.

Request:
If I would like make it by shell script, which target folder could let  me put
the driver in and let the volume disk be recognized ??
It is urgent for us!!
Thank you
Comment 1 Andrius Benokraitis 2007-10-05 10:10:59 EDT
Nick - Have you tried Fedora 7? I don't believe Fedora Core 6 is being actively
supported at this time.
Comment 2 Tom Coughlan 2007-10-05 11:46:09 EDT
The other bit of good news is that the Areca driver is built in to Fedora 7. You
will not need the driver disk at all. 
Comment 3 nickcheng 2007-10-07 22:37:46 EDT
Hi Andrius,
Yes, it happens on FC7 as well.
I am not sure about what you mean " Fedora Core 6 is being actively
supported at this time". If you mean the stuff for the inclusion of Areca driver
in installation disk, you are right because the FC6 kernel is 2.6.18-1.2798.fc6,
which is not yet included Areca driver, arcmsr.
Therefore I sitll built a driver disk for our customers.
I wish it could help our customers to load the driver buring the installation
process.
But it failed anyway.
Therefore I thought I could make a workaround which is to install the driver
manually through console , even though there is some problem on anaconda, but it
failed as well.
(In reply to comment #1)


Hi Tom,
I know it.
But because we have a new  dirver release for new product, we have to build a
driver disk to help the customers to load our driver during installation process.
Are there any ways that I can work around if there are some problems on anaconda?
BTW, is there any competition happened during the installation of FC7 which has
the default support of arcmsr driver, but I load the new driver with the same
name, arcmsr, through driver disk?
(In reply to comment #2)

Thank you,


Comment 4 Chuck Ebbert 2007-10-08 12:26:56 EDT
Respins of Fedora, with new kernels and install disks are available at:

http://spins.fedoraunity.org/spins

However it looks like they are providing Fedora 7 only.

Note You need to log in before you can comment on or make changes to this bug.