Bug 32030 - variable name problem in todo.py
Summary: variable name problem in todo.py
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-16 20:48 UTC by Eric Sandeen
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-16 20:48:03 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Eric Sandeen 2001-03-16 20:48:00 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-XFS i686)


In an upgrade install, if mount fails, the attempt to bring up a warning
dialog dies because of an invalid variable name.

Reproducible: Always
Steps to Reproduce:
1. Make an XFS (or non-ext2) root Red Hat install.  :-)
2. Try to upgrade it with wolverine
	

Actual Results:  Traceback (innermost last):
  File "/usr/bin/anaconda", line 509, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 1218, in run
    rc = apply (step[1](), (dir,) + step[2])
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/text.py", line 417, in
__call__
    todo.upgradeFindPackages (root)
  File "/var/tmp/anaconda-7.1//usr/lib/anaconda/todo.py", line 1099, in
upgradeFindPackages
    intf.messageWindow(("Dirty Filesystems"),
NameError: intf



Expected Results:  install should have proceeded.

--ALSO--

Is "Dirty Filesystems" really the right name for this message window?

Patch:

--- todo.py	Fri Mar 16 14:46:23 2001
+++ todo.py.orig	Fri Mar 16 14:46:05 2001
@@ -1105,7 +1105,7 @@
                                            self.fstab, self.instPath,
 					   allowDirty = 0)
 	    except SystemError, msg:
-		self.intf.messageWindow(("Dirty Filesystems"),
+		intf.messageWindow(("Mount Failure"),
 		    _("One or more of the filesystems listed in the "
 		      "/etc/fstab on your Linux system cannot be mounted. "
 		      "Please fix this problem and try to upgrade again."))

Comment 1 Matt Wilson 2001-03-16 21:39:18 UTC
was already fixed in CVS.



Note You need to log in before you can comment on or make changes to this bug.