Bug 32039 - linux-2.2.16 kernel compilation problem
linux-2.2.16 kernel compilation problem
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: kernel (Show other bugs)
7.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-16 19:18 EST by etaflin
Modified: 2007-04-18 12:32 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-16 19:18:14 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description etaflin 2001-03-16 19:18:11 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.75 [en] (X11; U; Linux 2.2.16-22 i686)


I have the same RH7.0 installation on a recent DELL Workstation PIII 800,
128M 
and on a old DELL Dimension PII 300, 64M
All kernels with config files in  /usr/src/linux compile on PIII
However no one of them compiles on the PII
where errors as follows are reported:

cdrom.c:422:75: warning: pasting would not give a valid preprocessing token
cdrom.c:480:88: warning: pasting would not give a valid preprocessing token
etc
etc

/usr/src/linux/include/linux/sunrpc/debug.h:53:57: warning: nothing can be
pasted after this token
{standard input}:1299: Warning: indirect lcall without `*'
make: *** [_dir_arch/i386/lib] Error 2

Reproducible: Always
Steps to Reproduce:
1.compile with PIII
2.compile with PII
3.
	

Actual Results:  same problem
Comment 1 Arjan van de Ven 2001-03-16 19:25:11 EST
There are 2 things you must do:
1) Use kgcc to compile the 2.2 kernels, it's there because the 2.2 kernel
   makes some (invalid) assumptions about the compiler, and the default
   "gcc" compiler is newer and doesn't grant all the assumptions
2) Run up2date to update your gcc anyway; there was a bug in the gcc that
   originally shipped in Red Hat 7.0

Note You need to log in before you can comment on or make changes to this bug.