Bug 3204 - cdplayer applet crashes kernel (might be syslog/kernel bug?)
cdplayer applet crashes kernel (might be syslog/kernel bug?)
Status: CLOSED DEFERRED
Product: Red Hat Linux
Classification: Retired
Component: distribution (Show other bugs)
6.0
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-02 01:26 EDT by Raul Acevedo
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-07-06 12:12:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Raul Acevedo 1999-06-02 01:26:34 EDT
I am not 100% sure that the GNOME CD player applet is
causing this, but it seems like the most likely culprit at
this point.

The problem is that Linux just freezes, randomly.  No
console error messages, just a complete machine freeze.
This only started happening last week; I've been using
RedHat 6.0 for several weeks now.

Here's why I believe it's the CD player applet:

 * It only happens when running X, and within a couple
minutes of running X.
 * It only started happening after I took out the CD from
the tray.  Before, I always kept a CD in the CD-ROM tray.
 * When there is no CD in the tray, the applet endlessly and
very frequently polls the CD-ROM.  This causes lots and lots
of syslog messages saying "kernel: cdrom: open failed."  I
think something overflows with syslogd, which causes the
kernel to panic.

Technically, if my theory is correct, this is really two
bugs: the cdplayer applet shouldn't be such a pain in the
arse that it polls the CD-ROM so frequently.  Then again,
this should obviously not crash the entire kernel.  Bad bad
bad.

BTW, it looks like this doesn't happen with my custom built
2.2.9 kernel.  I'm going to leave the machine on all night
with no CD in the tray and I'll respond with info on whether
it crashes or not.
Comment 1 David Lawrence 1999-06-07 15:25:59 EDT
I was able to get this to fail on a stock 6.0 install. Using tail -f
/var/log/messages, I noticed that when you stop a music cd, it is
reporting the following error:

Jun  7 15:22:53 mrhanky kernel: hdb: packet command error: error=0x54
Jun  7 15:22:53 mrhanky kernel: ATAPI device hdb:
Jun  7 15:22:53 mrhanky kernel:   Error: Illegal request -- (Sense
key=0x05)
Jun  7 15:22:53 mrhanky kernel:   Invalid field in command packet --
(asc=0x24, ascq=0x00)
Jun  7 15:22:53 mrhanky kernel:   The failed "Mode Select" packet
command was:  Jun  7 15:22:53 mrhanky kernel:   "55 10 0e 00 00 00 00
00 18 00 00 00 "
Jun  7 15:22:53 mrhanky kernel:   Error in command packet byte 256 bit
4
Comment 2 Raul Acevedo 1999-06-11 02:14:59 EDT
I forgot to respond to this earlier...

The bug doesn't happen with the 2.2.9 Linux kernel.  It also doesn't
happen with updated versions of the cdplayer_applet from the
gnome-core package (right now I'm using 1.0.5).  I am guessing the
crash problem was in the kernel...

However, the CD player applet still polls the CD-ROM drive
incessantly.  Does Linux have any way to automatically "wake up"
a process when a CD-ROM drive is inserted, to avoid this silly
situation where an application has to either continually poll the
CD-ROM drive to see if there's a CD in there, or it has to be told
explicitly by the user?
Comment 3 Michael Fulbright 1999-07-06 12:12:59 EDT
Unable to reproduce. Will keep an eye to see if problem resurfaces
for user.

Note You need to log in before you can comment on or make changes to this bug.