Bug 320421 - Review Request: cwrite - console editor
Review Request: cwrite - console editor
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
low Severity medium
: ---
: ---
Assigned To: Mamoru TASAKA
Fedora Extras Quality Assurance
http://cwrite-editor.hoter.ru
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 12:37 EDT by Desislav Georgiev
Modified: 2008-01-28 04:18 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-12-14 07:36:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
mtasaka: fedora‑review+
kevin: fedora‑cvs+


Attachments (Terms of Use)
gdb log from 0.1.22 (1.91 KB, text/plain)
2007-12-10 09:53 EST, Mamoru TASAKA
no flags Details

  None (edit)
Description Desislav Georgiev 2007-10-05 12:37:08 EDT
Spec URL: <http://cwrite-editor.hoter.ru/file/index>
SRPM URL: <http://cwrite-editor.hoter.ru/file/index>
Description: <Cwrite is a console editor. It supports C/C++ source and preprocessor blocks manipulation.>
Comment 1 Desislav Georgiev 2007-10-05 12:44:47 EDT
RPM packages have been made using nano rpm for Fedora 7.
Comment 2 Mamoru TASAKA 2007-11-29 06:07:28 EST
Please provide us the URLs for your spec/srpm from which
we can download them directly (by wget -N, for example) 
so that we can correctly know what spec/srpm you want to be reviewed.
Comment 3 Desislav Georgiev 2007-11-29 07:25:49 EST
(In reply to comment #2)
> Please provide us the URLs for your spec/srpm from which
> we can download them directly (by wget -N, for example) 
> so that we can correctly know what spec/srpm you want to be reviewed.

Thank you very much for being interested in review.
Here are the direct URLs:
Spec URL: <http://file047p.mylivepage.com/chunk47/1204371/865/cwrite.spec>
SRPM URL: <http://file047p.mylivepage.com/chunk47/1204371/865/cwrite-0.1.00-
1.fc7.src.rpm>

Comment 4 Desislav Georgiev 2007-11-29 07:29:19 EST
Thank you very much for being interested in review.
Here are the direct URLs:
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/865/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/865/cwrite-0.1.00-1.fc7.src.rpm>
Comment 5 Desislav Georgiev 2007-11-29 08:11:04 EST
Here are the direct URLs of the latest version:
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite-0.1.12-1.fc7.src.rpm>
Comment 6 Desislav Georgiev 2007-11-29 09:26:54 EST
(In reply to comment #2)
> Please provide us the URLs for your spec/srpm from which
> we can download them directly (by wget -N, for example) 
> so that we can correctly know what spec/srpm you want to be reviewed.

I am very sorry for the inconvinience, here are the direct URLs:
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite-0.1.12-1.fc7.src.rpm>
Comment 7 Mamoru TASAKA 2007-11-30 08:21:36 EST
First of all, it seems that this is your first submit of review
request. I guess you have to get sponsored, am I right?

http://fedoraproject.org/wiki/PackageMaintainers/Join
http://fedoraproject.org/wiki/PackageMaintainers/HowToGetSponsored
Comment 8 Mamoru TASAKA 2007-11-30 10:25:48 EST
For general packaging guideline, you can refer to
http://fedoraproject.org/wiki/Packaging/Guidelines
http://fedoraproject.org/wiki/Packaging/ReviewGuidelines

Well, for 0.1.12-1:
* License tag
  - Now the license tag "GPL" is invalid for Fedora.
    http://fedoraproject.org/wiki/Packaging/LicensingGuidelines
    http://fedoraproject.org/wiki/Licensing

* SourceURL
  - Please write the correct URL for Source0
    ("Correct" here means that from the written URL we can
     download the tarball used in srpm directly by "wget -N",
     for example).

* Parallel make support
  - Support parallel make if possible (please refer to
    the section "Parallel make" of "Guildlines" wiki page.

* Timestamps
  - When you use "cp" or "install" commands in spec file, 
    please add "-p" option to keep timestamps on installed
    files.

* chmod in %post
  - Why is this needed?

* info scriptlet
  - Please refer to the section "Texinfo" of
    http://fedoraproject.org/wiki/Packaging/ScriptletSnippets

* defattr
  - Now we recommend %defattr(-,root,root,-)

* Directory ownership issue
-------------------------------------------------
%files
%{_datadir}/%{name}/*
-------------------------------------------------
  - This causes:
-------------------------------------------------
[tasaka1@localhost ~]$ LANG=C rpm -qf /usr/share/cwrite/help.txt 
cwrite-0.1.12-1.fc9
[tasaka1@localhost ~]$ LANG=C rpm -qf /usr/share/cwrite
file /usr/share/cwrite is not owned by any package
-------------------------------------------------
    i.e. the directory %_includedir/%name is not owned by any package.
    You can fix this by
-------------------------------------------------
%files
%{_datadir}/%{name}/
-------------------------------------------------
    This contains the directory %_datadir/%name itself *and*
    all files/directories/etc under %_datadir/%name.

* Changelog
  - The contents of %changelog is strange :)

Comment 9 Desislav Georgiev 2007-12-03 13:34:07 EST
(In reply to comment #8)
Thank you very much for all remarks. I tried to fix all in 0.1.13
Info file is under development.
* chmod in %post
- This allows access to the passwd file when running with non-root user id, 
  for the screen lock function
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite-0.1.13-1.fc7.src.rpm>
Comment 10 Mamoru TASAKA 2007-12-04 11:26:12 EST
For 0.1.13-1:

* setuid/gid
  - Ah, you wrote "+s" Then:
    * You must not change the permission on %post. Instread
      you must specify the permission at %files section like:
-------------------------------------------------------
%files
%attr(4755,root,root) %{_bindir}/%{name}
-------------------------------------------------------
    * And if you want to use setuid, perhaps I have to ask
      RH security responsible team about this as we now consider 
      that using setuid/gid is generally dangerous. Is this
      "really" needed?

* License
  - Still the tag "GPL" is invalid.
    ! Note
      The COPYING file is GPLv3, however apart from this 
      file there are no files in the tarball which limits
      the version of GPL applied to only 3.
      Then we regard the license of this software as
      "GPL+" (i.e. "any version" of GPL) due to the section
      14 "Revised Versions of this License"

      Currently the license tag for this spec file is "GPL+".

* BuildRequires
  - Is autoconf needed for BuildRequires?

* %doc
  - Generally The file "INSTALL" 
      is for people who want to build and install the software 
      by themselves and is not needed for people who use rpm to 
      install the software.

* Requires(post,postun): /sbin/install-info
  - Why is this needed? This file does not contain any info
    files and actually post/postun scriptlets don't use install-info.
  - Also is "rm -f %{buildroot}%{_infodir}/dir" in %install
    really needed?

* Empty %preun
  - Please remove this.
Comment 11 Desislav Georgiev 2007-12-06 03:20:18 EST
(In reply to comment #10)
0.1.16-1 review request
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite-0.1.16-1.fc7.src.rpm>

Comment 12 Mamoru TASAKA 2007-12-06 11:27:16 EST
Rebuild failed at least on dist-f9, ppc
http://koji.fedoraproject.org/koji/taskinfo?taskID=279379
http://koji.fedoraproject.org/koji/getfile?taskID=279432&name=build.log

Note:
It is bad that autotools are called after configure ends.
Perhaps timestamps on some files are not proper.
Comment 13 Desislav Georgiev 2007-12-08 11:29:17 EST
(In reply to comment #12)
Build failed due to missing line for automake in cwrite configure.ac
I hope it's fixed.
0.1.17-1 review request
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite-0.1.17-1.fc8.src.rpm>


Comment 14 Mamoru TASAKA 2007-12-08 12:56:15 EST
Again build failed. I guess some files has unwilling timestamps.

http://koji.fedoraproject.org/koji/taskinfo?taskID=283439
Comment 15 Desislav Georgiev 2007-12-08 15:11:22 EST
(In reply to comment #14)
0.1.18-1 review request
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite-0.1.18-1.fc8.src.rpm>
Comment 16 Mamoru TASAKA 2007-12-09 08:13:20 EST
Again failed.
http://koji.fedoraproject.org/koji/taskinfo?taskID=284231

A. Please check Makefile.in and the timestamps of related
   files.

   For example,
   http://koji.fedoraproject.org/koji/getfile?taskID=284233&name=build.log
   says:
-------------------------------------------------------------------
   284  config.status: config.h is unchanged
   285  config.status: executing depfiles commands
   286  cd . && /bin/sh /builddir/build/BUILD/cwrite-0.1.18/missing --run autoheader
   287  /builddir/build/BUILD/cwrite-0.1.18/missing: line 52: autoheader:
command not found
   288  WARNING: `autoheader' is missing on your system.  You should only need it if
   289           you modified `acconfig.h' or `configure.ac'.  You might want
   290           to install the `Autoconf' and `GNU m4' packages.  Grab them
   291           from any GNU archive site.
   292  rm -f stamp-h1
----------------------------------------------------------------
   The corresponding part in Makefile.in is:
----------------------------------------------------------------
   240  $(srcdir)/config.h.in:  $(am__configure_deps) 
   241          cd $(top_srcdir) && $(AUTOHEADER)
   242          rm -f stamp-h1
   243          touch $@
-----------------------------------------------------------------
   This means that the timestamp of config.h.in is older than
   files written as $(am__configure_deps), autoheader is called
   automatically. To aviod this, you must "touch" config.h.in
   beforehand.

   The following suppresses autotools autocall.
-----------------------------------------------------------------
%prep
%setup -q
touch config.h.in aclocal.m4 configure Makefile.in
-----------------------------------------------------------------

   B. Even after this, make fails with the following
-----------------------------------------------------------------
   297  make[2]: Entering directory `/builddir/build/BUILD/cwrite-0.1.18/doc'
   298  make[2]: *** No rule to make target `all'.  Stop.
-----------------------------------------------------------------
      It seems that configure does not create doc/Makefile.
      Try "autoreconf -f -i".
Comment 17 Desislav Georgiev 2007-12-09 09:13:05 EST
(In reply to comment #16)
This time I run:
1) aclocal
2) automake
3) autoconf
on source directory, before creating the tarball.
This should allow building without autotools
I've checked the timestamp of doc/Makefile
I build with:
rpmbuild -ba cwrite.spec
and this invokes autotools in the build process, as specified above, that's 
why I missed these bugs. I am very sorry for the inconvinience.
The tag for your build.log is very useful for me, to resolve these problems,
thank you.
0.1.19-1
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite-0.1.19-1.fc8.src.rpm>

Comment 18 Mamoru TASAKA 2007-12-09 09:53:13 EST
Rebuild again failed...

http://koji.fedoraproject.org/koji/taskinfo?taskID=284318
http://koji.fedoraproject.org/koji/getfile?taskID=284319&name=build.log

It seems that the timestamps of the files in source tarball
is ahead of current time by more than 3 hours?
Comment 19 Desislav Georgiev 2007-12-09 11:38:26 EST
I set GMT during installation of Fedora 8, I corrected it :(
I run:
autoreconf -f -i
on source directory, as you advised me.
0.1.20-1 review request
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite-0.1.20-1.fc8.src.rpm>
Comment 20 Mamoru TASAKA 2007-12-10 02:20:07 EST
For 0.1.20-1:

* License
  - Now some files under src/ declares the license to be GPLv3+,
    please change the License tag to GPLv3+.

* permission in srpm
  - All files in srpm (including spec file) should have 0644
    permision.

* Missing BuildRequires
  - Rebuild again failed.
    http://koji.fedoraproject.org/koji/taskinfo?taskID=284996

    This time makeinfo (in texinfo rpm) is not found, so
    you have to add texinfo to BuildRequires.

* Info scripts
  - Please check the section "Texinfo" of
    http://fedoraproject.org/wiki/Packaging/ScriptletSnippets
    again. 
    - if [ $1 = 0 ]; then on %preun is missing
      (For this, please also check the section "Syntax" of
       the scriptlets wiki page)
    - || : is needed for --excludedocs install
Comment 21 Desislav Georgiev 2007-12-10 05:25:16 EST
(In reply to comment #20)
0.1.22-1 review request
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite-0.1.22-1.fc8.src.rpm>

Comment 22 Mamoru TASAKA 2007-12-10 09:53:58 EST
Created attachment 282841 [details]
gdb log from 0.1.22

Well, 0.1.22-1:
* %post scriptlets:
  - %post scriptlet should actually be:
------------------------------------------------
%post
/sbin/install-info %{_infodir}/%{name}.info.gz %{_infodir}/dir || :
------------------------------------------------
    as http://fedoraproject.org/wiki/Packaging/ScriptletSnippets
    says.
    i.e. [ $1 -eq 1 ] must be removed on %post because
    the texinfo file must be updated also when cwrite version
    is upgraded.

* And
  - When I just typed $ cwrite on console, cwrite SEGVed.
    gdb log is attached.
Comment 23 Desislav Georgiev 2007-12-10 13:14:37 EST
(In reply to comment #22)
0.1.23-1 review request
Spec URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite.spec>
SRPM URL:
<http://file047p.mylivepage.com/chunk47/1204371/988/cwrite-0.1.23-1.fc8.src.rpm>
Comment 24 Mamoru TASAKA 2007-12-11 08:52:08 EST
Okay. Now cwrite itself is okay.
Then as this is a NEEDSPONSOR ticket:

-------------------------------------------------------------
NOTE: Before being sponsored:

This package will be accepted with another few work. 
But before I accept this package, someone (I am a candidate) 
must sponsor you.

Once you are sponsored, you have the right to review other 
submitters' review requests and approve the packages formally. 
For this reason, the person who want to be sponsored (like you) 
are required to "show that you have an understanding 
of the process and of the packaging guidelines" as is described
on :
http://fedoraproject.org/wiki/PackageMaintainers/HowToGetSponsored

Usually there are two ways to show this.
A. submit other review requests with enough quality.
B. Do a "pre-review" of other person's review request
   (at the time you are not sponsored, you cannot do
   a formal review)

When you have submitted a new review request or have pre-reviewed other 
person's review request, please write the bug number on this bug report 
so that I can check your comments or review request.

Fedora package collection review requests which are waiting for someone to
review can be checked on:
http://fedoraproject.org/PackageReviewStatus/NEW.html
(NOTE: please don't choose "Merge Review")


Review guidelines are described mainly on:
http://fedoraproject.org/wiki/Packaging/ReviewGuidelines
http://fedoraproject.org/wiki/Packaging/Guidelines
http://fedoraproject.org/wiki/Packaging/ScriptletSnippets
------------------------------------------------------------
Comment 25 Desislav Georgiev 2007-12-12 15:16:55 EST
(In reply to comment #24)
I've read thoroughly several approved packages, 
I will try to assist in a package pre-review, following the:
http://fedoraproject.org/wiki/Packaging/ReviewGuidelines
I will try to co-operate in bug 248678
Comment 26 Mamoru TASAKA 2007-12-13 01:17:51 EST
You may want to pre-review more recent ticket (i.e. more bigger
bug number) as old review requests are generally less active.
Comment 27 Desislav Georgiev 2007-12-13 05:02:36 EST
(In reply to comment #26)
Thank you, Mr Tasaka.
I made some helpful remarks in bug 417111
Comment 28 Mamoru TASAKA 2007-12-13 06:15:38 EST
Well, autually there are some other problems with bug 417111
by some reasons... however your comments are okay for initial
comment.

------------------------------------------------------------------
           This package (cwrite) is APPROVED by me
------------------------------------------------------------------

!
Please follow the procedure according to:
http://fedoraproject.org/wiki/PackageMaintainers/Join
from "Get a Fedora Account".
At a point a mail should be sent to sponsor members which notifies
that you need a sponsor (at the stage, please also write on
this bug for confirmation that you requested for sponsorship)
Then I will sponsor you.

If you want to import this package into Fedora 7/8, you also have
to look at
http://fedoraproject.org/wiki/Infrastructure/UpdatesSystem/Bodhi-info-DRAFT
(after once you rebuilt this package on Fedora rebuilding system).

If you have questions, please ask me.
Comment 29 Mamoru TASAKA 2007-12-13 07:20:10 EST
Now I should be sponsoring you.
Comment 30 Desislav Georgiev 2007-12-13 07:48:31 EST
(In reply to comment #28)

Thank you very much for approval, Mr. Tasaka!
This is my first package, and I need a sponsorship.
I created a Fedora Account.
I would like to import cwrite into Fedora 7/8,
and I would like to participate in Fedora project, and development.
Comment 31 Mamoru TASAKA 2007-12-13 07:57:12 EST
Now I should be sponsoring you. Please follow
"Join" wiki again.
Comment 32 Desislav Georgiev 2007-12-13 08:55:50 EST
New Package CVS Request
=======================
Package Name: cwrite
Short Description: console editor
Owners: desi
Branches: F-7 F-8
InitialCC: desi mtasaka
Cvsextras Commits: yes
Comment 33 Kevin Fenzi 2007-12-13 14:09:19 EST
cvs done.
Comment 34 Desislav Georgiev 2007-12-14 03:08:23 EST
(In reply to comment #31)
I rebuilt the first package cwrite-0.1.23-1 successfully.
http://koji.fedoraproject.org/koji/taskinfo?taskID=293013
Following the wiki instructions, it is up to me to close this thicket
as NEXTRELEASE
Comment 35 Mamoru TASAKA 2007-12-14 08:02:07 EST
Please rebuild your package also on F-8 repository and
request to push on bodhi.
Comment 36 Desislav Georgiev 2008-01-21 05:17:01 EST
(In reply to comment #35)
Mr Tasaka,

The package approved by you, cwrite-0.1.23 has been successfully moved into
dist-f8-updates and dist-f7-updates. 
I have also pushed cwrite-0.1.24, which has many bugs fixed. 
Recently I have developed xcwrite, which is a X implementation of cwrite.
May I learn more about what the sponsorship means?

Comment 37 Mamoru TASAKA 2008-01-21 05:32:46 EST
(In reply to comment #36)
> I have also pushed cwrite-0.1.24, which has many bugs fixed. 
If you want to update cwrite, please follow
http://fedoraproject.org/wiki/PackageMaintainers/UpdatingPackageHowTo
and
http://fedoraproject.org/wiki/Infrastructure/UpdatesSystem/Bodhi-info-DRAFT

> Recently I have developed xcwrite, which is a X implementation of cwrite.
If you want to import xcwrite into Fedora, please file a new review
request as
http://fedoraproject.org/wiki/PackageMaintainers/NewPackageProcess

> May I learn more about what the sponsorship means?
Well, this is written in
http://fedoraproject.org/wiki/PackageMaintainers/SponsorProcess

Comment 38 Desislav Georgiev 2008-01-24 04:21:31 EST
(In reply to comment #37)
> > May I learn more about what the sponsorship means?
> Well, this is written in
> http://fedoraproject.org/wiki/PackageMaintainers/SponsorProcess
> 
I have expected sponsorship in the true meaning of the word, or reward for the
work I have done, as all new package contributors probably do.
It is hard to believe that all people participating in Fedora development, do
not receive any reward for the work they do.
I really don't understand what all people working for the open source community,
live on.
The acceptance of the package in the distribution is really great, but I also
expected a chance to earn my living.
Nothing personal, I really appreciate your participation in the promotion of the
package. :)
Comment 39 Desislav Georgiev 2008-01-28 03:58:15 EST
(In reply to comment #37)
I really appreciate the ideas and the work of the open source community.
There is a Bulgarian law, regarding e-signature. It defines "e-signature"
in a vague and simplified way, however, uses the terms "public" and "private key".
Further on, 5 Bulgarian companies are "certified" to "generate" and service
e-signatures for all people in Bulgaria. Every single service, for example,
generating a key, or "installing the key on a single computer" costs about 100
USD. In Bulgaria only the keys generated and serviced by these companies are
valid e-signatures.
I am aware of PGP - GnuPG story, which is one of the most remarkable events in
GNU history. It really concerns freedom, and rights.
The e-signatures, generated by the above mentioned Bulgarian companies, are
certainly PGP or GnuPG implementation. This is not explicitly declared neither
in the law, nor in their work.
I have signed the Fedora CLA agreement with a GnuPG generated key. Does that
make the agreement invalid? Or, are local Bulgarian laws above international,
monopolizing recognized international software and thus, profiting hundreds of
millions dollars? I greatly doubt if the "proper management" and "usage" of the
keys, mentioned in the law, is possible without the international key servers.
Mr Tasaka, can the open source community verify the software, used by these
companies to implement PGP? Or, verify the lawfulness of the implicit usage, and
restrictions, applied by Bulgarian government on PGP implementations?
Comment 40 Mamoru TASAKA 2008-01-28 04:18:46 EST
Please don't ask here. This is a review request. Also
I cannot make a "formal" judgment for any "legal" issues as such.

Perhaps you can ask questions about FAS (Fedora Account system)
as written on:
http://fedoraproject.org/wiki/Infrastructure/AccountSystem/Contact
or you can ask on fedora-devel-list.

Note You need to log in before you can comment on or make changes to this bug.