Bug 32048 - up2date crashes because of RPM conflict
Summary: up2date crashes because of RPM conflict
Status: CLOSED DUPLICATE of bug 32280
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: up2date   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
high
Target Milestone: ---
Assignee: Preston Brown
QA Contact: Jay Turner
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-17 03:06 UTC by Magnus Johansson
Modified: 2015-01-07 23:44 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 02:46:20 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Magnus Johansson 2001-03-17 03:06:24 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux 2.4.2 i686; en-US; 0.7) Gecko/20010203


When selecting to upgrade Xconfigurator to version 4.9.19 release 1,
up2date crashes completely with an error message:
"There was a fatal RPM error. The message was:
The package kudzu-0.97.6-1 conflicts with: mouseconfig"



Reproducible: Always
Steps to Reproduce:
1.Run up2date on a 7.1 Beta 2 system with kudzu-0.97.6-1 installed
2.Select Xconfigurator 4.9.19-1 to be installed
3.Click Next.
	

Actual Results:  Error message shows up, and up2date crashes completely.

Expected Results:  Conflict should have been reported without up2date crashing.

Comment 1 Adrian Likins 2001-03-19 19:12:58 UTC
was there any other error message other than the report that there
was a conflict in the package set? If it existed after this, then that
is the currently expected behaviour. If there was a traceback or other
error messages, then this is unexpected.

Better handling of conflicts is going to be worked on for the next version.

This particular conflict seems to be an error in the package set that
is available on the beta server that probable needs to get resolved.


Comment 2 Magnus Johansson 2001-03-20 02:46:10 UTC
No other error message was reported than the conflict. When I pressed Ok in the
message dialog box, the up2date-application was terminated. A more reasonable
behavior would have been to continue with other packages selected and just skip
the one that had a conflict.

It also took a while to pin-point which selected package to upgrade that had the
conflict. This was never reported, only the one already installed package was
reported.



Comment 3 Preston Brown 2001-03-22 17:09:40 UTC

*** This bug has been marked as a duplicate of 32280 ***


Note You need to log in before you can comment on or make changes to this bug.