Bug 32081 - [PATCH] make kernel.h generation more robust
Summary: [PATCH] make kernel.h generation more robust
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: initscripts   
(Show other bugs)
Version: 1.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-17 12:57 UTC by Andrew Bartlett
Modified: 2014-03-17 02:19 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-22 16:31:39 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to rc.sysinit for better kernel.h generation (1.05 KB, patch)
2001-03-17 12:58 UTC, Andrew Bartlett
no flags Details | Diff

Description Andrew Bartlett 2001-03-17 12:57:22 UTC
This patch (attached) allows the kernel.h to be generated even if the
current kernel is not installed from an RPM.   It uses 'uname -m' to
determine the arch value.

It also correctly generates the macros in kernel.h, with actual values of 0
and 1 (the old version breaks /usr/include/linux/rhconfig.h, at least the
version I have.).

The reason I looked into this is that I wanted to rebuild sendmail, so
theres also a dependeny there.

Comment 1 Andrew Bartlett 2001-03-17 12:58:38 UTC
Created attachment 12865 [details]
Patch to rc.sysinit for better kernel.h generation

Comment 2 Bill Nottingham 2001-03-22 16:31:34 UTC
Is that patch reversed?

Comment 3 Bill Nottingham 2001-03-22 17:12:10 UTC
Yes, it apparently is. Added in 5.79-1.


Note You need to log in before you can comment on or make changes to this bug.