Bug 320861 - Red Hat Developer Studio EAR build problems
Red Hat Developer Studio EAR build problems
Product: Red Hat Developer Suite
Classification: Retired
Component: eclipse (Show other bugs)
All Windows
low Severity medium
: ---
: ---
Assigned To: Marshall Culpepper
Depends On:
  Show dependency treegraph
Reported: 2007-10-05 16:56 EDT by Stephen Westbom
Modified: 2008-11-27 08:58 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-11-27 08:58:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Stephen Westbom 2007-10-05 16:56:17 EDT
Publish doesn't pick up specified jars in the org.eclipse.wst.common.component
file where the XML elements is like this example:

<dependent-module archiveName="tomahawk-sandbox.jar" deploy-path="/"

within a wb-module element
Comment 1 Ben Konrath 2007-10-09 17:52:11 EDT
Reassiging to JBossIDE team.
Comment 2 Marshall Culpepper 2007-10-09 21:58:38 EDT
This has been moved over to JBossTools JIRA here:

Stephen, can you create a JBoss JIRA User ID and add yourself as a watcher there?
Comment 3 Max Rydahl Andersen 2007-10-10 03:54:13 EDT
Yes - Stephan, please follow up on that one in our jira.

Especially with info on how you got that element in there (or if it was just 
pure hacking with the .component file ;)
Comment 4 Stephen Westbom 2007-10-10 10:25:15 EDT
No hack, these were entries made through project properties/Java Build Path/Add
Variable/Extend (M2_REPO)/ in a 3.2 version of Eclipse.

The only thing I see that cannot be done that way is the archiveName attribute
of the dependent-module element.  Has support for this been dropped?  It is an
important indirection in the very redundant configuration settings within the
Eclipse projects plugins (hasn't anyone heard of storing the same information
once, not numerous times in different configuration files for different plug-ins).

I don't want the manifest file's classpath entries for my war to have to deal
with version numbers for jars so I use the archiveName attribute (which works
just fine in 3.2)
Comment 5 Stephen Westbom 2007-10-10 10:27:24 EDT
BTW M2_REPO is the Maven 2 local repository directory. For example on my XP
environment it is:

C:/Documents and Settings/myUserName/.m2/repository
Comment 6 Andrew Overholt 2007-10-10 11:41:59 EDT
Why isn't there a Red Hat Developer Studio bugzilla entry under Products?  This
bug is currently filed against the old Red Hat Developer Suite.
Comment 7 Bryan Che 2007-10-10 11:48:07 EDT
JBoss uses Jira, not Bugzilla.

Comment 8 Stephen Westbom 2007-10-10 11:52:23 EDT
Sorry about that,  I think this is a branding issue.  The product is called Red
Hat Developer Studio not JBoss Developer Studio.  It is not very clear to me as
an end user where it belongs because of this (I think you should thank your
marketing department for that).

It was the closest product link I could find on the Red Hat site.  How about a
link to the JBoss area from Red Hat to make it clearer for this product or call
it JBoss Developer Studio and make your branding versus support clearer to
Comment 9 Andrew Overholt 2007-10-10 12:17:51 EDT
(In reply to comment #7)
> JBoss uses Jira, not Bugzilla.
> http://jira.jboss.com/jira/browse/RHDS

Then this should be closed as upstream or something.
Comment 10 Andrew Overholt 2007-10-10 12:18:29 EDT
(In reply to comment #8)
> Sorry about that,  I think this is a branding issue.

It's not your fault, Stephen :)
Comment 11 Max Rydahl Andersen 2008-11-27 08:58:15 EST
This bug should not be in here so closing it.

btw. no follow up were done on https://jira.jboss.org/jira/browse/JBIDE-1062 and we could not reproduce so we resolved it. Please create separate issue in JBIDE jira if still an issue.

And the product is actually named JBoss Developer Studio now ;)

Note You need to log in before you can comment on or make changes to this bug.