Bug 320871 - ata_generic missing from installation CD
ata_generic missing from installation CD
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 17:13 EDT by Nicolas Pitre
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-12 10:55:46 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nicolas Pitre 2007-10-05 17:13:54 EDT
Description of problem:
The ata_generic module is missing from the install CD, making
installation on old PATA based system impossible.

Version-Release number of selected component (if applicable):


How reproducible:
Require an old PATA based system, like a Toshiba 2140CDS laptop.

Steps to Reproduce:
1. insert install CD
2. select any partitioning scheme
3. no disk can be selected
  
Actual results:
Error message about no suitable disk device.

Expected results:
The /dev/sda choice is offered.

Additional info:
Hacking the install CD to include ata_generic.ko, and manually inserting
libata.ko and ata_generic.ko using the shell console before the partition
choice screen is presented allows for a successful install.
This is true for Fedora 7 install as well.
Comment 1 Jeremy Katz 2007-10-12 10:55:46 EDT
We had removed it because it was causing problems by matching "better". 
Improved our matching and added it back 

Note You need to log in before you can comment on or make changes to this bug.