Bug 321051 - ath5k: kernel oops
ath5k: kernel oops
Status: CLOSED DUPLICATE of bug 254192
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 19:21 EDT by Martin Jürgens
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 15:06:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Jürgens 2007-10-05 19:21:21 EDT
Description of problem:
Using Fedora 8 Test 3, I get a kernel OOPS after booting. 

I do not really know if this is related to the problem, but I thought it may be
usable for you, also. Using Fedora 8 Test 3 (and Test 2), I can neither run
iwconfig nor I can run ath5k. The program runs endless and I can not type
anything to that console then. Also, I can not login using gdm. The autologin
does not work, and after logging in using the username "fedora" or "root", I am
not able to interact with gdm. When I move my mouse over "language" for example,
the element changes its look, but clicking on it does not work.

Smolt profile here:
http://smolt.fedoraproject.org/show?UUID=c843173f-61b8-4bbd-a9ca-624f2f842cb7

How reproducible:
Every Time.

Additional info:

Oct  5 22:57:57 localhost kernel: BUG: unable to handle kernel NULL pointer
dereference at virtual address 00000000
Oct  5 22:57:57 localhost kernel: printing eip: f8b1e331 *pde = 26317067 *pte =
00000000 
Oct  5 22:57:57 localhost kernel: Oops: 0000 [#1] SMP 
Oct  5 22:57:57 localhost kernel: Modules linked in: rfcomm l2cap bluetooth
sunrpc dm_mirror dm_multipath video output sbs battery ac ipv6 floppy
snd_hda_intel arc4 ecb blkcipher snd_seq_dummy rc80211_simple snd_seq_oss
snd_seq_midi_event snd_seq snd_seq_device snd_pcm_oss snd_mixer_oss snd_pcm
dvb_usb_dtt200u dvb_usb dvb_core ath5k snd_timer i2c_nforce2 snd forcedeth
mac80211 parport_pc button i2c_core soundcore k8temp sg parport snd_page_alloc
hwmon cfg80211 ext3 jbd mbcache dm_snapshot dm_mod squashfs sd_mod ata_generic
pata_amd sata_nv libata ohci_hcd ehci_hcd loop sr_mod scsi_mod cdrom
Oct  5 22:57:57 localhost kernel: CPU:    0
Oct  5 22:57:57 localhost kernel: EIP:    0060:[<f8b1e331>]    Not tainted VLI
Oct  5 22:57:57 localhost kernel: EFLAGS: 00210246   (2.6.23-0.214.rc8.git2.fc8 #1)
Oct  5 22:57:57 localhost kernel: EIP is at ath5k_hw_reset+0x39c/0xcd0 [ath5k]
Oct  5 22:57:57 localhost kernel: eax: 00000000   ebx: f55ba000   ecx: 00000000
  edx: 00000005
Oct  5 22:57:57 localhost kernel: esi: 00000000   edi: 00000000   ebp: e6316b28
  esp: e6316ac4
Oct  5 22:57:57 localhost kernel: ds: 007b   es: 007b   fs: 00d8  gs: 0033  ss: 0068
Oct  5 22:57:57 localhost kernel: Process NetworkManager (pid: 2550, ti=e6316000
task=eb5d8d60 task.ti=e6316000)
Oct  5 22:57:57 localhost kernel: Stack: c05021e8 e6316b0c f8b184e0 f5dd1190
f5b6c830 00000002 f5dd2f4c f5dd2f44 
Oct  5 22:57:57 localhost kernel:        00000000 00000000 00000001 f8ae37d9
00000003 00000001 00000002 00000014 
Oct  5 22:57:57 localhost kernel:        e6316b0c 00000000 00000000 00000000
f5dd0fe0 f55ba600 f55ba000 f5dd0fe0 
Oct  5 22:57:57 localhost kernel: Call Trace:
Oct  5 22:57:57 localhost kernel:  [<c0406463>] show_trace_log_lvl+0x1a/0x2f
Oct  5 22:57:57 localhost kernel:  [<c0406513>] show_stack_log_lvl+0x9b/0xa3
Oct  5 22:57:57 localhost kernel:  [<c04066d3>] show_registers+0x1b8/0x289
Oct  5 22:57:57 localhost kernel:  [<c04068af>] die+0x10b/0x23e
Oct  5 22:57:57 localhost kernel:  [<c06350ec>] do_page_fault+0x51c/0x5ed
Oct  5 22:57:57 localhost kernel:  [<c0633812>] error_code+0x72/0x78
Oct  5 22:57:57 localhost kernel:  [<f8b18a82>] ath_init+0x74/0xfb [ath5k]
Oct  5 22:57:57 localhost kernel:  [<f8b18b9f>] ath_open+0xb/0xd [ath5k]
Oct  5 22:57:57 localhost kernel:  [<f8ad05d8>] ieee80211_open+0x259/0x320
[mac80211]
Oct  5 22:57:57 localhost kernel:  [<c05ceb36>] dev_open+0x31/0x6c
Oct  5 22:57:57 localhost kernel:  [<c05ccc8d>] dev_change_flags+0xa3/0x156
Oct  5 22:57:57 localhost kernel:  [<c05d4868>] do_setlink+0x1c1/0x28d
Oct  5 22:57:57 localhost kernel:  [<c05d5a5c>] rtnl_setlink+0xc9/0xe5
Oct  5 22:57:57 localhost kernel:  [<c05d52dc>] rtnetlink_rcv_msg+0x1a1/0x1bb
Oct  5 22:57:57 localhost kernel:  [<c05e2a5d>] netlink_run_queue+0x6f/0xe1
Oct  5 22:57:57 localhost kernel:  [<c05d50f1>] rtnetlink_rcv+0x29/0x42
Oct  5 22:57:57 localhost kernel:  [<c05e2ee1>] netlink_data_ready+0x15/0x56
Oct  5 22:57:57 localhost kernel:  [<c05e1e38>] netlink_sendskb+0x1f/0x37
Oct  5 22:57:57 localhost kernel:  [<c05e2726>] netlink_unicast+0x1ab/0x1c5
Oct  5 22:57:57 localhost kernel:  [<c05e2ec0>] netlink_sendmsg+0x271/0x27d
Oct  5 22:57:57 localhost kernel:  [<c05c352a>] sock_sendmsg+0xe7/0x104
Oct  5 22:57:57 localhost kernel:  [<c05c3698>] sys_sendmsg+0x151/0x1af
Oct  5 22:57:57 localhost kernel:  [<c05c4725>] sys_socketcall+0x220/0x241
Oct  5 22:57:57 localhost kernel:  [<c040522e>] syscall_call+0x7/0xb
Oct  5 22:57:57 localhost kernel:  =======================
Oct  5 22:57:57 localhost kernel: Code: 00 00 03 5a 08 89 fa c7 44 24 04 00 00
00 00 0f b6 46 1c 89 04 24 8b 45 ac e8 50 cf ff ff 89 da 0f b7 c0 e8 b1 59 9e c7
ff 45 e8 <0f> b7 07 83 c6 14 39 45 e8 72 b0 8b 4d ac 83 79 48 01 76 51 66 
Oct  5 22:57:57 localhost kernel: EIP: [<f8b1e331>] ath5k_hw_reset+0x39c/0xcd0
[ath5k] SS:ESP 0068:e6316ac4
Comment 1 Gordon Messmer 2007-10-06 15:38:11 EDT
This bug appears to be a duplicate of 254192
Comment 2 John W. Linville 2007-10-08 15:06:52 EDT

*** This bug has been marked as a duplicate of 254192 ***

Note You need to log in before you can comment on or make changes to this bug.