Bug 321091 - POT file needs updating; different from intltool created one
POT file needs updating; different from intltool created one
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: pirut (Show other bugs)
6
All Linux
low Severity low
: ---
: ---
Assigned To: Jeremy Katz
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-05 19:30 EDT by Dimitris Glezos
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 21:21:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dimitris Glezos 2007-10-05 19:30:41 EDT
## Description of problem:

Static POT file is different from the dynamic one (intltool):

$ msgfmt --statistics *pot
0 translated messages, 178 untranslated messages.

$ intltool-update --pot
[glezos@shuttle po]$ msgfmt --statistics *pot
0 translated messages, 177 untranslated messages.

This might cause confusion to translators, since some of them will try to
`msgmerge` with the POT file instead of running `intltool-update <lang>`.

I guess best practice is either to completely remove the POT file (a new
translator will either get the msgmerged PO from translate.fpo or need the whole
source code to produce the PO/POT) or have the POT up2date by always using
`intltool-update --pot` to update the POT file.

Note: the stats page create the POT on the fly.
Comment 1 Jeremy Katz 2007-10-08 21:21:45 EDT
Hrmmm -- for some reason, the pot file wasn't being updated on 'make dist' as 
it should be.  Even a 'make -C po pirut.pot' was saying nothing to be done. 
Forced it to update and then tried touching files and the right thing seems to
happen, so should hopefully go away.

Note You need to log in before you can comment on or make changes to this bug.