Bug 32121 - mixup with configuration files
Summary: mixup with configuration files
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: tetex   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Tim Waugh
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-18 08:21 UTC by Michal Jaegermann
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-07 17:31:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Michal Jaegermann 2001-03-18 08:21:34 UTC
'texconfig' modifies /usr/share/texmf/dvips/config/config.ps but
'dvips', and 'xdvi', finds via 'kpathsea' library another config
file in /usr/share/texmf/dvips/base/config.ps .  The net effect
is that configuration changes are not effective, apparently "random"
bitmap files are generated and printing fails as no print command
is defined.   Also, if printing to a file, an output has a wrong
resolution and is in A4 format even if 'letter' was requested.

To fix a file base/config.ps should be renamed, or simply removed, or
made into a link to config/config.ps.  Finding that and repairing will
be highly non-trivial for people without a close knowledge of a layout
of a TeX installation and 'kpathsea'.

  Michal
  michal@harddata.com

Comment 1 Tim Waugh 2001-03-18 11:27:10 UTC
Yes.  This is a regression from 1.0.7-7.  Thanks for the report.

Comment 2 Tim Waugh 2001-03-18 16:17:02 UTC
This is caused by the dvipsk586.patch in dvipsk-jpatch-p1.5b.tar.gz.

Matt, do you know why this patch installs base/config.ps?  Who made this 
patch, so that I can ask them?


Comment 3 Matt Wilson 2001-03-18 16:23:50 UTC
ASCII in Japan.  I have no idea who to talk to.


Comment 4 Michal Jaegermann 2001-03-18 16:33:54 UTC
I would strongly suspect that this is an overenthusiastic patching.  Old
versions of tetex did use dvips/base/config.ps for a configuration file
and it is likely coming from there.  At the first look this seems to be
a regular "sample" config.ps and nothing more.

'dvips' will look for 'config.ps' anywhere in that tree (look into
web2c/texmf.cnf) and that is the problem because it is finding the wrong
one; "wrong" in that sense that 'texconfig' writes specifically to
dvips/config/config.ps


Comment 5 Glen Foster 2001-03-19 20:29:20 UTC
This defect considered MUST-FIX for Florence Gold

Comment 6 Tim Waugh 2001-03-19 21:16:36 UTC
How does it help ASCII in Japan?  I don't see it..

I'm edging towards just reverting that particular change.


Comment 7 Tim Waugh 2001-03-19 22:09:55 UTC
Ah, there is a newer version of the dvipsk-jpatch patchset (1.5d), which fixes 
this.


Comment 8 Tim Waugh 2001-03-20 10:27:48 UTC
Fixed in tetex-1.0.7-14.


Comment 9 Tim Waugh 2001-08-07 17:31:27 UTC
I have changed things in this area to finally get Japanese dvips working.

Now there is 'dvips' and 'pdvips', and texmf.cnf has different settings for 
pdvips.

This bug _should_ still be closed, but I'm reopening it to make sure, until 
it's verified.

1.0.7-27.



Note You need to log in before you can comment on or make changes to this bug.