Bug 32122 - Wolverine won't install on a 20GB disk
Wolverine won't install on a 20GB disk
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael Fulbright
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-18 05:04 EST by Robin Atwood
Modified: 2008-05-01 11:38 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 10:56:32 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Robin Atwood 2001-03-18 05:04:19 EST
I have a 20GB disk with 2490 cylinders. Disk Druid will not use this disk
during an install. RH 6.2 graphical install will allow you to use fdisk to
create a partition and Druid allows you ypu to select this one. When I 
tried the Wolverine FTP install, it treated the fdisk warnings as fatal 
and would not present the 20GB disk in the select partition dialog. Thus
I am unable to install.
Comment 1 Michael Fulbright 2001-03-20 00:04:08 EST
What were the fdisk warnings?
Comment 2 Robin Atwood 2001-03-20 05:13:22 EST
[root@opal print]# fdisk /dev/hdb
The number of cylinders for this disk is set to 2490.
There is nothing wrong with that, but this is larger than 1024,
and could in certain setups cause problems with:
1) software that runs at boot time (e.g., LILO)
2) booting and partitioning software from other OSs
   (e.g., DOS FDISK, OS/2 FDISK)

I always use cfdisk to create partitions and that gives no warnings. The XOSL
loader and latest lilo have no problems with large disks either. The FTP 
install sees the warning (I guess) and presents a message box inviting you to 
skip the disk!
Comment 3 Robin Atwood 2001-03-21 06:03:31 EST
Sorry, should have added fdisk does not like the partitions boundaries, this is
the error message install barfs with. Using the RH6.2 CDROM I get the same 
messages but can proceed after creating the new partition (/dev/hdb4). I have 
never experienced any problems with these partitions! The FTP install should 
treat this situation as non-fatal.

[root@opal /root]# fdisk -l /dev/hdb
 
Disk /dev/hdb: 255 heads, 63 sectors, 2490 cylinders
Units = cylinders of 16065 * 512 bytes
 
   Device Boot    Start       End    Blocks   Id  System
/dev/hdb1             1       763   6126592+   5  Extended
Partition 1 does not end on cylinder boundary:
     phys=(762, 185, 63) should be (762, 254, 63)
/dev/hdb2   *       763       959   1572984   82  Linux swap
Partition 2 does not end on cylinder boundary:
     phys=(958, 141, 63) should be (958, 254, 63)
/dev/hdb3           959      1089   1047784+   e  Win95 FAT16 (LBA)
/dev/hdb4          1090      2090   8040532+  83  Linux
/dev/hdb5             1         1      1953   78  Unknown
/dev/hdb6             1        16    124960+  82  Linux swap
/dev/hdb7            16       265   1999840+  83  Linux
/dev/hdb8           265       763   3999712+  83  Linux
Comment 4 Michael Fulbright 2001-04-02 12:04:57 EDT
Could you append the output of /proc/ide/hdb/geometry when booted until 6.2?

Also from the 7.0 installer. To get this you need to switch to VC2 (cntl-alt-f2)
 and then you can see a command prompt, where you can type

cat /proc/ide/hdb/geometry

For some reason the 2.4 kernel seems to think your disk geometry is different
than the 2.2 kernel in 6.2 did.
Comment 5 Robin Atwood 2001-04-03 07:11:33 EDT
I tried boot.img and bootnet.ing from Wolverine and neither allow Alt-F2 to get
to a command prompt. Also 'linux rescue' still puts you into the install.
On 6.2 the geometry is:
physical     39693/16/63
logical      2490/255/63

On 7.1 I can see the logical geometry is the same from the mount messages. I
think the difference is that with RH6.2 I used the graphical install which
allows you to use fdisk and then Druid. The geometry warnings are ignored. The
text install treats them as fatal.
HTH
Comment 6 Michael Fulbright 2001-04-03 18:30:38 EDT
Try these update images (make an ext2 floppy, copy these onto it, then
boot the installer like 'linux updates expert', and insert the floppy when
prompted).

When it asks about a driver disk say 'No'.

Please let me know if this helps!

The files you want are:

  ftp:/people.redhat.com/~msf/bug32122/*.so



Comment 7 Robin Atwood 2001-04-04 08:13:55 EDT
Tried the update but got 'cpio failed on anaconda/newtpyfsedit.so: no space 
left on device'. Looks like the RAM drive is full. Maybe you could create a 
new bootnet.img?
Comment 8 Michael Fulbright 2001-04-04 10:27:57 EDT
Could you try running 'strip' on the two .so files, should make them alot
smaller.  I forgot to do that.

Try that out first.
Comment 9 Robin Atwood 2001-04-05 09:04:30 EDT
I did the strip and now get 'error 2 reading header: cpio: bad magic'
I tried two diskettes and the same result. Any idea? I will be away until 
Monday.
Comment 10 Michael Fulbright 2001-04-05 10:56:28 EDT
Hmm we might be too different in versions for the update to work as I had hoped
it might.

I've tested this internally with a partition table like yours and it is working
fine.  The final release will have this fix so you'll be able to install it.

Thanks for your help in resolving this issue.

Note You need to log in before you can comment on or make changes to this bug.