Bug 321281 - Crash on initializing network -- pxeboot, e100, compaq tc1000
Crash on initializing network -- pxeboot, e100, compaq tc1000
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
bzcl34nup
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-06 07:07 EDT by Tomasz Melcer
Modified: 2008-09-08 15:12 EDT (History)
2 users (show)

See Also:
Fixed In Version: Fedora release 9
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-09-08 15:12:35 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Tomasz Melcer 2007-10-06 07:07:09 EDT
Description of problem:
I am trying to install Fedora using pxe on compaq tc1000 laptop. PXE works,
kernel starts up, I can choose language and means to get Fedora (http/ftp/...).
When asked to initialize networking (either using dhcp or after entering IPs
manually), installer crashes displaying garbage on the screen.

I've got debian on this machine (installed by pxe), so I can do some testing.

This happens when trying to use pxe images for F8t3, F8t2 and F7. FC6 works ok.

Version-Release number of selected component (if applicable):
Anaconda: 11.3.0.36

How reproducible:
Always

Steps to Reproduce:
1. Setup PXE environment and fed it with Fedora 7, 8t2 or 8t3 images.
2. Boot laptop, choosing PXE.
3. Wait for anaconda dialogs.
4. Choose english, us keyboard, any of http/ftp/nfs, enable ipv4+dhcp.

Actual results:
Screen displays randomly distributed cyrillic characters (looks like the same
every time, but I'm not sure). Kernel doesn't respond to sysrq calls.

Additional info:
TC1000 components:
00:00.0 Host bridge: Transmeta Corporation LongRun Northbridge (rev 03)
00:00.1 RAM memory: Transmeta Corporation SDRAM controller
00:00.2 RAM memory: Transmeta Corporation BIOS scratchpad
00:05.0 VGA compatible controller: nVidia Corporation NV11 [GeForce2 Go] (rev b2)
00:07.0 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super South] (rev 40)
00:07.1 IDE interface: VIA Technologies, Inc.
VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:07.4 ISA bridge: VIA Technologies, Inc. VT82C686 [Apollo Super ACPI] (rev 40)
00:07.5 Multimedia audio controller: VIA Technologies, Inc. VT82C686 AC97 Audio
Controller (rev 50)
00:07.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller
(rev 30)
00:08.0 Ethernet controller: Intel Corporation 82551QM Ethernet Controller (rev 10)
00:0a.0 Ethernet controller: Atmel Corporation at76c506 802.11b Wireless Network
Adaptor (rev 11)
00:0b.0 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller
(rev 01)
00:0b.1 CardBus bridge: Texas Instruments PCI1520 PC card Cardbus Controller
(rev 01)
00:0c.0 USB Controller: NEC Corporation USB (rev 41)
00:0c.1 USB Controller: NEC Corporation USB (rev 41)
00:0c.2 USB Controller: NEC Corporation USB 2.0 (rev 02)
Comment 1 Chuck Ebbert 2007-10-09 16:29:13 EDT
Is there anything displayed on console 4?
Comment 2 Tomasz Melcer 2007-10-09 17:45:08 EDT
Before clicking "ok" in the "Configure TCP/IP" dialog (5 last lines, typed
manually):

<7>sd 0:0:0:0: [sda] Mode Sense: 00 3a 00 00
<5>sd 0:0:0:0: [sda] Write cache: enabled, read cache: enabled, doesn't support
DPO or FUA
<6> sda: sda1 sda2 < sda5 sda6 sda7 >
<5>sd 0:0:0:0: [sda] Attached SCSI disk
<4>loader used greatest stack depth: 868 bytes left

(whole screen is filled with lines about scsi or ata; i can't scroll up)

After clicking "ok" I can't change VC, even when I press alt-sysrq-r firstly.
Comment 3 Bug Zapper 2008-04-04 10:01:11 EDT
Based on the date this bug was created, it appears to have been reported
during the development of Fedora 8. In order to refocus our efforts as
a project we are changing the version of this bug to '8'.

If this bug still exists in rawhide, please change the version back to
rawhide.
(If you're unable to change the bug's version, add a comment to the bug
and someone will change it for you.)

Thanks for your help and we apologize for the interruption.

The process we're following is outlined here:
http://fedoraproject.org/wiki/BugZappers/F9CleanUp

We will be following the process here:
http://fedoraproject.org/wiki/BugZappers/HouseKeeping to ensure this
doesn't happen again.
Comment 4 Tomasz Melcer 2008-07-12 10:32:24 EDT
Just tried F9, seems to work ok.
Comment 5 Peter van Egdom 2008-09-08 15:12:35 EDT
Thanks for reporting back. Closing bug as per comment #4.

Note You need to log in before you can comment on or make changes to this bug.