Bug 321331 - Radeon driver: Option "AGPFastWrite" "1" in xorg.conf causes a system hang
Radeon driver: Option "AGPFastWrite" "1" in xorg.conf causes a system hang
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: xorg-x11-drv-ati (Show other bugs)
8
All Linux
low Severity low
: ---
: ---
Assigned To: X/OpenGL Maintenance List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-06 09:32 EDT by Mark van Rossum
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 11:09:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Xorg.0.log (43.99 KB, application/octet-stream)
2007-10-07 06:57 EDT, Mark van Rossum
no flags Details
xorg.conf which leads to hang (3.21 KB, application/octet-stream)
2007-10-07 06:58 EDT, Mark van Rossum
no flags Details

  None (edit)
Description Mark van Rossum 2007-10-06 09:32:19 EDT
Description of problem:
When using the radeon driver, 
Option "AGPFastWrite" "1" in xorg.conf causes a system hang.

Now, Xorg.log explicitly warns against this option. However, the problem is 
that it caused no harm in the driver shipped with F7.
So people might suddenly end up with a non-working system.

(Fixing it can be a bit tricky if xdm/kdm is used. You can do it by booting 
from another device, mounting the f8 partition, and removing xorg.conf).


Version-Release number of selected component (if applicable):
     xorg-x11-drv-ati-6.7.194-3.fc8
Hardware:
     ATI9600 FireGL card

How reproducible:
Everytime.

Additional info:
Comment 1 Matěj Cepl 2007-10-07 05:01:24 EDT
Thanks for the bug report.  We have reviewed the information you have provided
above, and there is some additional information we require that will be helpful
in our diagnosis of this issue.

Please attach your X server config file (/etc/X11/xorg.conf) and X server log
file (/var/log/Xorg.*.log) to the bug report as individual uncompressed file
attachments using the bugzilla file attachment link below.

Could you please also try to run without any /etc/X11/xorg.conf whatsoever and
let X11 autodetect your display and video card? Attach to this bug
/var/log/Xorg.0.log from this attempt as well, please.

We will review this issue again once you've had a chance to attach this information.

Thanks in advance.
Comment 2 Mark van Rossum 2007-10-07 06:57:59 EDT
Created attachment 218661 [details]
Xorg.0.log
Comment 3 Mark van Rossum 2007-10-07 06:58:42 EDT
Created attachment 218671 [details]
xorg.conf which leads to hang
Comment 4 Mark van Rossum 2007-10-07 06:59:05 EDT
Hi,

It runs fine when xorg.conf is absent.
Files attached
Comment 5 Matěj Cepl 2007-10-09 11:09:04 EDT
I am sorry, but I don'ŧ understand why I should not close it as NOTABUG -- you
do something against which you are explicitly warned not to do, and when you
remove /etc/X11/xorg.conf entirely it works. Closing as NOTABUG, but if you have
any reason for me, why I should reopen, go ahead and make a comment to this bug.

Note You need to log in before you can comment on or make changes to this bug.