Bug 32134 - japanese.map is invalid
japanese.map is invalid
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: tetex (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Tim Waugh
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-18 14:35 EST by Michal Jaegermann
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-05 15:20:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2001-03-18 14:35:57 EST
File dvips/config/japanese.map is invalid as it does not specify .pfb,
or .pfa, files from which these fonts are supposed to come (not mentioning
encoding but maybe this is ok).  Compare with other map files in the same
directory.

This deficiency is causing later spurious wailings from pdftex and
pdflatex and maybe from other programs as well.

  Michal
  michal@harddata.com
Comment 1 Tim Waugh 2001-03-18 17:07:17 EST
Can you tell me how I can see these wailings?  Do you have a test case?
Comment 2 Michal Jaegermann 2001-03-18 18:46:26 EST
Oh, I see what is happening.  After one added some new font maps, or one
changed font configuration options (turning on support for CM in
Type1 format, for example in 'updmap') then one is supposed to rerun
/usr/share/texmf/dvips/config/updmap to generate new 'psfonts.map'.
It looks like that although japanese.map was added, and also got listed
on 'extra_modules' list in updmap, nobody bothered to execute updmap.
Therefore old maps were not updated and and you do not see anything
wrong.  I was playing with 'type1_default' and was hit by that.

BTW - I checked that 'cmpskit' (cf. #31957) does not add a single pfb file
to what is in the current tetex distribution and only some buggy scripts.
The only useful piece of that package seems to be 'cmsample.tex'.
Turn on 'type1_default=true', rerun 'updmap', and do 'pdftex cmsample.tex'
just for fun of it.  This should also show complaints if you kept
japanese.map in updmap configuration.

Regardless - japanese.map simply does not conform to a required format.
Comment 3 Tim Waugh 2001-03-20 06:25:19 EST
Is this the same as bug #17333?  It seems related.
Comment 4 Tim Waugh 2001-04-04 16:51:16 EDT
http://www.io.com/~kazushi/unix/ptex.html#psfontsmap says this:

-->
Changing a psfonts.map for printer having no Japanese fonts

Edit /usr/local/share/texmf/dvips/psfonts.map. Add "<`min" and "<`goth" like 
following.
rml      Ryumin-Light-H         <`min
rmlv     Ryumin-Light-V         <`min
gbm      GothicBBB-Medium-H     <`goth
gbmv     GothicBBB-Medium-V     <`goth


In addition, I describe meanings of name. "rml" is a font name in DVI file. 
"Ryumin-Light-H" is a font name in PS file. "min is a font name in VFlib.
<--

Does this sound like the right solution? (Bug #17333 is a separate issue I 
think.)
Comment 5 Michal Jaegermann 2001-04-05 15:20:48 EDT
> Does this sound like the right solution?

This for sure would make these map entries acceptable in that sense
that they would contain a minimal number of required elements. The
last one is a name of a file from which glyphs description will be
read.  How "'min" is suppposed to be interpreted in the context
I am not sure and even less what ' means here.  Usually you see there
names like "lbfa.pfb" or "xyline10.pfa".
Comment 6 Tim Waugh 2001-04-19 05:30:01 EDT
This fix is in tetex-1.0.7-16, anyhow.

Note You need to log in before you can comment on or make changes to this bug.