This service will be undergoing maintenance at 20:00 UTC, 2017-04-03. It is expected to last about 30 minutes
Bug 321381 - fancontrol shell script syntax error
fancontrol shell script syntax error
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: lm_sensors (Show other bugs)
rawhide
All Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-06 11:36 EDT by Steve Grubb
Modified: 2015-03-04 20:19 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-08 09:28:30 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Grubb 2007-10-06 11:36:01 EDT
Description of problem:
Bash detects a syntax error in the fancontrol script. This means it will
probably not run correctly.

sh -n /usr/sbin/fancontrol
/usr/sbin/fancontrol: line 334: syntax error near unexpected token `<'
/usr/sbin/fancontrol: line 334: `                       read < <(exec sleep 1)'

I think the read command needs a variable to receive the input being sent to it.
There is another one like this at line 372. I am rating this high severity since
a malfunctioning fan can cause the system to shutdown.

Version-Release number of selected component (if applicable):
lm_sensors-2.10.4-2.fc8

Additional info:
F7 has the same problem.
Comment 1 Hans de Goede 2007-10-08 09:28:30 EDT
Well, then you shouldn't start it with sh but with bash:
[hans@localhost ~]$ cat /usr/sbin/fancontrol | head -n 1
#!/bin/bash

Closing as works for me.

Note You need to log in before you can comment on or make changes to this bug.