Bug 32157 - an innocent-looking space before 'nameserver' in resolv.conf confuses resolver
Summary: an innocent-looking space before 'nameserver' in resolv.conf confuses resolver
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: binutils (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
low
Target Milestone: ---
Assignee: Jakub Jelinek
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-18 21:27 UTC by Dan Kenigsberg
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-18 21:27:49 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Dan Kenigsberg 2001-03-18 21:27:46 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.16-22 i686)


I added a space just before the nameserver keyword in /etc/resov.conf. 
This resulted in a failure to find a default dns.


Reproducible: Always
Steps to Reproduce:
1. just start a nameserver line with a space
	

Actual Results:  for example, nslookup says the address of the Default
Server is 0.0.0.0

Comment 1 Jakub Jelinek 2001-03-19 15:05:10 UTC
The resolv.conf format does not allow space there, so it was not innocent.
glibc has never allowed spaces there and I don't think it is necessary to
make changes for this. Note that e.g. Solaris does not allow spaces there either.

Comment 2 Dan Kenigsberg 2001-03-19 21:29:21 UTC
Ok, so it's not a bug, but it is sure ugly.

P.S. The bug is probably in kppp which made the first space initially. But I
fail to reproduce this one...


Note You need to log in before you can comment on or make changes to this bug.