Bug 32158 - Sun JDK crashes X server
Summary: Sun JDK crashes X server
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
(Show other bugs)
Version: 7.0
Hardware: i386 Linux
medium
high
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-18 21:58 UTC by David Baron
Modified: 2007-04-18 16:32 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-20 12:00:02 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description David Baron 2001-03-18 21:58:57 UTC
Using many GUI java programs with the Sun JDK crashes my X server.  (Using
Sun's Java plugin in Mozilla also sometimes crashes my X server, so I
uninstalled the plugin.)


My X server is XF86_SVGA on a "Matrox|MGA G400 AGP" with 32MB of video
RAM and running at 1600x1200 at 24bpp.  Relevant installed packages (which
were installed by the RH7 installer) are:

XFree86-4.0.1-1
XFree86-75dpi-fonts-4.0.1-1
XFree86-SVGA-3.3.6-33
XFree86-devel-4.0.1-1
XFree86-libs-4.0.1-1
XFree86-tools-4.0.1-1
XFree86-twm-4.0.1-1
XFree86-xdm-4.0.1-1
XFree86-xfs-4.0.1-1

I also have a number of truetype fonts installed.


Steps to reproduce (on my machine):

Download, extract the RPM, and install the Sun JDK
http://java.sun.com/j2se/1.3/download-linux.html and add
/usr/java/jdk1.3.0_02/bin/ to PATH.

Download and unzip http://sis.cmis.csiro.au/svg/svgtoolkit-20001211.zip
and run the command

java -cp svg.jar:lib/xerces.jar:lib/ss_css2.jar:lib/js.jar
org.csiro.svg.viewer.Viewer

in the directory that is created.  (It's the command listed in view.sh,
roughly.)

Mouse over the toolbar in window that pops up.  This causes the X server
to crash.


I see similar problems with Sun's JDK on other GUI java programs, and
I've also seen X server crashes triggered by java applets on web pages
while using Sun's Java plugin with Mozilla.  I don't see the crashes
using the IBM JDK.

Comment 1 Mike A. Harris 2001-03-20 07:55:02 UTC
Please try the latest XFree86 release 4.0.3-1 at:

ftp://people.redhat.com/mharris

You'll need the 4.0.3 packages as well as Mesa 3.4-13 also available there.
In addition you may need to upgrade a few other RPM's from rawhide.
Does it solve the problem for you?

Comment 2 David Baron 2001-04-26 15:06:58 UTC
I upgraded to the XFree86-4.0.3-5 packages (I forget whether I got them from
rawhide or from the RH 7.1 distro).  But anyway, instead of crashing the X
server, it now crashes the font server and hangs the X server, which is even
worse since I need to connect from another machine to restart the font server
and kill the X server...

Comment 3 Mike A. Harris 2001-05-12 14:14:56 UTC
The recommended JVM to use is the IBM one, but only after reading the
release notes for Seawolf (Red Hat Linux 7.1).  Suns JVM is broken.

It shouldn't kill X though, so the bug report is valid.


Note You need to log in before you can comment on or make changes to this bug.