Bug 3216 - Outdated version of mgetty with broken vgetty
Summary: Outdated version of mgetty with broken vgetty
Keywords:
Status: CLOSED NEXTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mgetty
Version: 6.0
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: David Lawrence
QA Contact:
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1999-06-02 19:18 UTC by ard
Modified: 2008-05-01 15:37 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 1999-06-02 22:02:34 UTC


Attachments (Terms of Use)

Description ard 1999-06-02 19:18:00 UTC
The mgetty-1.1.14 distribution contains a broken vgetty
implementation.
This has by long been fixed (more than a year ago to be
exact. Fixes entered the mgetty tree around june).
Please include a fixed vgetty, and a more secure mgetty.
Use at least 1.1.18 (That is what I'm using. Keeps me from
backing up my sources myself), and 1.1.20 seems to be even
better. (1.1.18 works for me).
And another thing:
The spec is not really clean.
It copies the entire policy.h from the patch into the source
tree.
Actually the policy.h-dist should be copied from the
original source to policy.h, and only then patched.

Comment 1 Jeff Johnson 1999-06-02 22:02:59 UTC
Fixed (by upgrading) in mgetty-1.1.20-1.

BTW, I don't understand your comment about copying policy.h-dist
to policy.h: that is exactly what was happening in spec file.


Note You need to log in before you can comment on or make changes to this bug.