Bug 321891 - Evolution local delivery insists on a directory, which send/receive won't accept
Evolution local delivery insists on a directory, which send/receive won't accept
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: evolution (Show other bugs)
7
x86_64 Linux
low Severity high
: ---
: ---
Assigned To: Matthew Barnes
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-07 06:00 EDT by Kamal Shaker
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-07 10:10:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
GNOME Desktop 352346 None None None Never

  None (edit)
Description Kamal Shaker 2007-10-07 06:00:17 EDT
Description of problem: 

Evolution won't let me change the local delivery options for account. Is insists
on a directory (it won't let me select a file from the option box), then when
using send/receive it complains "Error while fetching mail. Could not open mail
file /home/xxx is a directory".

Mail is delivered to a users home directory /home/xxx/Mailbox. Even if I edit
.gconf/apps/evolution/mail/%gconf.xml to have the correct value, evolution
overwrites the new value. Even setting the file to read only or owned by root
won't stop evolution overwriting it.

This was discovered just I changed the "check for new mail" value, it appears to
overwrite the other entries no matter what I change.

Also other people are seeing this, I can't use the work around they suggest
though: http://www.fedoraforum.org/forum/showthread.php?t=158161

Version-Release number of selected component (if applicable):
evolution-2.10.3-4.fc7 (all updates applied)

How reproducible: Very

Steps to Reproduce:
1. In evolution, go into a "local delivery" account, change any setting and save
2. Click "send/receive"
3. You should get the above error, nothing I can see will fix it.
  
Actual results:

The above error. No new email delivered

Expected results:

Mail delivered to users inbox.

Additional info:

Now I have tried this on my account, I can't pick up my email :-( So please send
any questions to shakerky@googlemail.com for this bug so I can respond.
Comment 1 Matthew Barnes 2007-10-07 10:10:33 EDT
This has been fixed in Fedora 8.  See [1] for more details about it.

The workaround suggested in the forum is wrong; you should never edit the
%gconf.xml file directly because the "gconfd" server won't know about your
changes.  Instead, edit your settings using Configuration Editor.

  yum install gconf-editor
  Applications -> System Tools -> Configuration Editor

[1] http://bugzilla.gnome.org/show_bug.cgi?id=352346

Note You need to log in before you can comment on or make changes to this bug.