Bug 3219 - High network traffic causes snmpd to seg fault
High network traffic causes snmpd to seg fault
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux
Classification: Retired
Component: ucd-snmp (Show other bugs)
6.0
All Linux
high Severity high
: ---
: ---
Assigned To: David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 1999-06-02 15:57 EDT by fdragon
Modified: 2008-05-01 11:37 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-06-12 19:32:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description fdragon 1999-06-02 15:57:23 EDT
When this is read by snmpd to report stats for mrtg, snmpd
will die. This is install of RedHat 6.0, with addition of
mrtg, MySQL, and some perl libraries all in RPM format.

This makes it hard to use SNMP to monitor the machines.

=====----- BEGIN cat /proc/net/dev -----=====
[jrothste@www jrothste]$ cat /proc/net/dev
Inter-|
Receive                                                |
Transmit
 face |bytes    packets errs drop fifo frame compressed
multicast|bytes    packets errs drop fifo colls carrier
compressed
    lo: 5272882   39868    0    0    0     0
0         0  5272882   39868    0    0    0     0
0          0
  eth0:2235709667 11573352    1    0    0     0
0         0 3739544558 11742385    0    0    0 210896
0          0
  eth1:1624327485 4789640    0    0    0     0
0         0 1072228659 3884288    0    0    0 147391
83          0
[jrothste@www jrothste]$
=====-----  END  cat /proc/net/dev -----=====
Comment 1 Jeff Johnson 1999-06-05 12:35:59 EDT
I'm changing this component to ucd-snmp because that's where
the fix will be.

The easiest workaround is to rebooot the machine in order to reset
the counters that are causing the snmpd segfault. There may also
be a more precise way (than renbooting) to reset the ethernet
counters.

------- Email Received From  Jason Rothstein <fdragon@io.com> 06/07/99 12:24 -------
Comment 2 eric 1999-06-11 15:42:59 EDT
Fixed in the ucd-snmp 3.6.2 release. The snmp daemon now rolls over
rather than core dumps when the size of the traffic counter exceeds 32
bits. MRTG has no problem with that happening, though its counts may
be off for the 5 minutes where the rollover happened. I have 3.6.2
RPM's at ftp://ftp.estinc.com/pub/unsupported and will upload them to
a Red Hat incoming site as soon as someone tells me how.

  -- Eric Lee Green, Enhanced Software Technologies Inc.
       eric@estinc.com
Comment 3 Jeff Johnson 1999-06-12 19:32:59 EDT
Fixed (by upgrading) in ucd-snmp-3.6.2-1. Thanks for the report.

Note You need to log in before you can comment on or make changes to this bug.