Bug 32197 - XFree 4.0.2 no-workie above 800x600 for SIS 620 chipset
XFree 4.0.2 no-workie above 800x600 for SIS 620 chipset
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
Depends On:
  Show dependency treegraph
Reported: 2001-03-18 21:33 EST by bam
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-19 08:48:12 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description bam 2001-03-18 21:33:45 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)

Xfree has a garbled display when run above 800x600 (any pixel depth) on an
SiS 620 chipset.  Resolutions of 640x480 and 800x600 work fine.  There is
something specific to Wolverine, as it works fine when dual-booted to RH7.0
+ XFree 4.0.2.
In addition if Wolverine is updated to tonight's release of XFree 4.0.3
then the SiS 620 driver works as it should

Reproducible: Always
Steps to Reproduce:
1.Install wolverine on a system with a SiS 620 display
2.Select res above 800x600 (for example 1024x768x16bpp)

Actual Results:  Display is badly garbled.  Huge block cursor, verticle
lines, artifacts

Expected Results:  A clean X display

This system is based on the AsusTek MES-N (NLX form factor) MB w/ built in
SiS 620 controller using 8192MB memory.
Comment 1 Mike A. Harris 2001-03-19 00:17:17 EST
Ok, please expand on "if updated to XFree 4.0.3 it works properly".  Are
you saying you've installed 4.0.3 yourself from sources or a bindist?  If
so, and it isn't my RPM's, can you download and try my RPM's of 4.0.3 and
see if they work for you?  If you are using 4.0.3 from elsewhere and it
works, and my package doesn't, it could be a compiler issue, or perhaps
some patch is breaking things.  Anyway, update this asap so we can try to track
it down.


Get Mesa 3.4-13 also in addition to XFree86.

Comment 2 bam 2001-03-19 08:02:18 EST
Install of the XFree 4.0.3 was done by downloading the binaries
from ftp.xfree.org:/pub/XFree86/4.0.3/binaries/Linux-ix86-glibc22
and running the Xinstall.sh script.

Comment 3 bam 2001-03-19 08:48:02 EST
I just tried the RPMs from:

And they worked.  I had saved a backup of /etc/X11 and of /usr/X11R6 prior to
doing the
4.0.3 upgrade from ftp.xfree.org.  To test the above rpms I first rm -rf
/etc/X11 /usr/X11R6
and then restored the tar'd backup.  Then I applied the above RPMs.  I think
that pretty
well exercised the fix.  This evening I could try a full Wolverine re-install
and apply the RPMs
if feel that is useful.

Comment 4 Preston Brown 2001-03-19 15:21:49 EST
fixed in rawhide.

Note You need to log in before you can comment on or make changes to this bug.