Bug 32217 - (GeForce 2)QA0309, X locks up machine at startup, Creative Labs Annihilator II
(GeForce 2)QA0309, X locks up machine at startup, Creative Labs Annihilator II
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-19 04:42 EST by Edward Kuns
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-09 01:57:26 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Edward Kuns 2001-03-19 04:42:28 EST
This is a problem new with QA0309, not seen with any previous beta.
Install goes fine.  (I have to "ide=nodma" due to another problem,
unrelated.  Ignoring this, install goes fine.)  I can boot to run
level 1, 3, no problem.  Booting to run level 5, X hangs the machine
immediately after displaying the GDM login window.

Complete lockup.  No response to CTRL-ALT-DEL.

Also new with QA0309, not seen with any other beta, perhaps related...
the installer seems to alternately pick the X installer and the
text installer.  No rhyme or reason.  Same exact behavior on my
part in terms of what I type at in the installer gives different
behavior, seemingly alternating between X and text install.

Given these two, I'm guessing some instability has been added to
the latest XFree86 for nvidia GTS chips.  The CL Annihilator II
is detected as Generic GTS.  X has worked perfectly for all previous
betas for this card.  (Once I realized the early-beta installer hang
at X was due to using USB mouse!)
Comment 1 Mike A. Harris 2001-03-19 13:43:56 EST
I don't know for certain what a Creative Annihilator is, but I'm assuming
it is a sound card.  If you remove it, and install, does the problem go away?

It makes no sense at all that you would get a random text/gui install
at boot time unless your machine is doing something really strange.  Make
sure you do not have any "Plug and Play aware OS" enabled in your BIOS and
try again.

This has nothing to do with X IMHO.  I'll run it by the installer team to
see if they have any ideas, but AFAICS, this is a NOTABUG.
Comment 2 Edward Kuns 2001-03-19 13:59:02 EST
The Annihilator is my X card!!!  Keywords above, "Generic GTS"
and "nvidia GTS."
Comment 3 Edward Kuns 2001-03-19 14:00:36 EST
Note that I get this strange behavior ONLY with QA0309.  NOT with
RC-2, not with Wolverine, not with beta-3, not with beta-1.
Comment 4 Edward Kuns 2001-03-19 14:05:53 EST
Just checked ... "PNP OS" is indeed set to "No" in my BIOS.
Comment 5 Preston Brown 2001-03-19 15:22:44 EST
probably a kernel crash.
Comment 6 Mike A. Harris 2001-03-19 15:25:00 EST
Please provide file attachments of:

lspci -v
lspci -vn
Your XF86Config-4 and X server logs.
Comment 7 Mike A. Harris 2001-04-09 01:29:51 EDT
Without the above info I cannot proceed.
Comment 8 Edward Kuns 2001-04-09 01:57:22 EDT
I've been working with 0401 today, installing various different ways, and
I don't have any problems.  Looks like this was 0309 only, not earlier
versions, and is fixed by 0401.  Thanks.
Comment 9 Mike A. Harris 2001-04-09 07:04:34 EDT
Ok great, glad it's working for you now.  Thanks for updating the bug report
quickly so I can close it.

Latest rawhide version is 4.03-5 should fix any problems others may have like
this.

Take care!

Note You need to log in before you can comment on or make changes to this bug.