Bug 322301 - scim-launcher crashed
scim-launcher crashed
Status: CLOSED DUPLICATE of bug 237439
Product: Fedora
Classification: Fedora
Component: scim-pinyin (Show other bugs)
7
i386 Linux
low Severity high
: ---
: ---
Assigned To: Peng Huang
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-07 12:45 EDT by LuoYuhong
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-19 05:16:15 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description LuoYuhong 2007-10-07 12:45:17 EDT
Description of problem:

After I updated to the neariest, Every program that use scim as the input method
is not useable forever. I find scim-launcher cause this

Version-Release number of selected component (if applicable):
1.4.5-21.f7

How reproducible:


Steps to Reproduce:
1.
[jason@LYH-T40 tmp]$ scim 
Smart Common Input Method 1.4.5

Launching a SCIM daemon with Socket FrontEnd...
Loading simple Config module ...
Creating backend ...
Launching a SCIM process with x11...
Loading simple Config module ...
Creating backend ...
SCIM has exited abnormally.


2.

[jason@LYH-T40 tmp]$ gdb /usr/lib/scim-1.0/scim-launcher -c core.18681 
GNU gdb Red Hat Linux (6.6-15.fc7rh)
Copyright (C) 2006 Free Software Foundation, Inc.
GDB is free software, covered by the GNU General Public License, and you are
welcome to change it and/or distribute copies of it under certain conditions.
Type "show copying" to see the conditions.
There is absolutely no warranty for GDB.  Type "show warranty" for details.
This GDB was configured as "i386-redhat-linux-gnu"...
Using host libthread_db library "/lib/libthread_db.so.1".

warning: Can't read pathname for load map: Input/output error.
Reading symbols from /usr/lib/libscim-1.0.so.8...Reading symbols from
/usr/lib/debug/usr/lib/libscim-1.0.so.8.1.1.debug...done.
done.
Loaded symbols for /usr/lib/libscim-1.0.so.8
Reading symbols from /lib/libdl.so.2...done.
Loaded symbols for /lib/libdl.so.2
Reading symbols from /usr/lib/libstdc++.so.6...done.
Loaded symbols for /usr/lib/libstdc++.so.6
Reading symbols from /lib/libm.so.6...done.
Loaded symbols for /lib/libm.so.6
Reading symbols from /lib/libgcc_s.so.1...done.
Loaded symbols for /lib/libgcc_s.so.1
Reading symbols from /lib/libc.so.6...done.
Loaded symbols for /lib/libc.so.6
Reading symbols from /lib/ld-linux.so.2...done.
Loaded symbols for /lib/ld-linux.so.2
Reading symbols from /usr/lib/scim-1.0/1.4.0/Config/simple.so...Reading symbols
from /usr/lib/debug/usr/lib/scim-1.0/1.4.0/Config/simple.so.debug...done.
done.
Loaded symbols for /usr/lib/scim-1.0/1.4.0/Config/simple.so
Reading symbols from /lib/libnss_files.so.2...done.
Loaded symbols for /lib/libnss_files.so.2
Reading symbols from /usr/lib/scim-1.0/1.4.0/IMEngine/m17n.so...done.
Loaded symbols for /usr/lib/scim-1.0/1.4.0/IMEngine/m17n.so
Reading symbols from /usr/lib/libm17n.so.0...done.
Loaded symbols for /usr/lib/libm17n.so.0
Reading symbols from /usr/lib/libm17n-core.so.0...done.
Loaded symbols for /usr/lib/libm17n-core.so.0
Reading symbols from /usr/lib/scim-1.0/1.4.0/IMEngine/pinyin.so...done.
Loaded symbols for /usr/lib/scim-1.0/1.4.0/IMEngine/pinyin.so
Core was generated by `/usr/lib/scim-1.0/scim-launcher -d -c simple -e all -f
socket --no-stay'.
Program terminated with signal 11, Segmentation fault.
#0  0x002bbaf2 in PhraseLib::input ()
   from /usr/lib/scim-1.0/1.4.0/IMEngine/pinyin.so
(gdb) 

3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Jens Petersen 2007-10-11 21:14:10 EDT
Are you able to reproduce this?

And if so what if you uninstall scim-pinyin?
Comment 2 LuoYuhong 2007-10-16 00:21:19 EDT
yes, if uninstall scim-pinyin, everything is ok

I recompiled scim and scim-pinyin, but don't resolve it.

I think if I downgrade libstc++ to the previous release, will resolve it
Comment 3 Jens Petersen 2007-10-16 01:05:53 EDT
Oh what is your version of libstc++?
Comment 4 Peng Huang 2007-10-16 01:17:27 EDT
remove folder ~/.scim/pinyin/ and try again. I think some files in this folder
have problems.
Comment 5 LuoYuhong 2007-10-16 01:38:20 EDT
oh, yes

but, what happened? this problem occured after the libstdc++ updated.

Comment 6 Peng Huang 2007-10-19 05:16:15 EDT
I checked scim-pinyin's user files. They are all text files. They should not be
related to stdc++. 

*** This bug has been marked as a duplicate of 237439 ***

Note You need to log in before you can comment on or make changes to this bug.