Bug 322351 - firstboot hangs after set date&time
firstboot hangs after set date&time
Status: CLOSED DUPLICATE of bug 227234
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
All Linux
medium Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
Depends On:
  Show dependency treegraph
Reported: 2007-10-07 13:36 EDT by Riku Seppala
Modified: 2008-02-06 12:56 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2008-02-06 12:56:32 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Riku Seppala 2007-10-07 13:36:34 EDT
Description of problem:

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. boot for the first time
2. firstboot, set date&time and click forward
Actual results:
system hangs, mouse doesn't move. Only way out is to press the power button.

Expected results:

Additional info:
fedora 8 test 3 x86_64 on HP dv9000z series laptop. I had to use the interactive
startup to boot.

platform x86_64?
Comment 1 Chris Lumens 2007-10-09 15:11:22 EDT
Are you using rhgb or not?  Most people are, but if you have removed the rhgb
option from your kernel boot parameters or didn't install the package (because
you deselected it, did a text mode install, etc.) then you're not.
Comment 2 Riku Seppala 2007-10-09 16:28:29 EDT
yes, using rhgb.

Just guessing here, could it be problem contacting the time server? Right now
kde clock is unable to contact time server.
Comment 3 Chris Lumens 2007-10-10 10:07:19 EDT
Perhaps there's something we can do regarding timeouts and error handling in
system-config-date, then.
Comment 4 Nils Philippsen 2007-10-11 07:42:26 EDT
I can't think of why contacting the time server should cause the mouse to hang,
it shouldn't even cause the GUI to not refresh.

Riku, did you enable NTP in the firstboot step? If yes, can you check if running
system-config-date normally (i.e. not from within firstboot, but all other
settings similarly) works?
Comment 5 Riku Seppala 2007-10-11 10:03:00 EDT
Just tested system-config-date, system hangs always. 
Comment 6 Nils Philippsen 2007-10-11 11:27:08 EDT
(In reply to comment #5)
> Just tested system-config-date, system hangs always. 

Does it only do this when you configure NTP or also when you switch NTP off?
Comment 7 Riku Seppala 2007-10-11 12:00:32 EDT
Also when NTP is off. When NTP is off it hangs immediately I press OK, with NTP
enabled I see the message connecting to NTP for a few second then it hangs.
Comment 8 Nils Philippsen 2007-10-11 12:32:13 EDT
I suspect that your box freezes when the hardware clock is set. Please check if
the following command (as root) freezes your system as well:

/sbin/hwclock --systohc
Comment 9 Riku Seppala 2007-10-11 13:01:04 EDT
yes it freezes
Comment 10 Nils Philippsen 2007-10-11 13:16:22 EDT
This seems to be either a HW-related kernel bug or a flaw in the hardware that
eventually has to be worked around. Changing component to kernel.
Comment 11 Jarod Wilson 2007-10-11 14:10:06 EDT
There were a few other bug reports regarding system hangs when touching the
system clock. I think they *should* be fixed by the latest rawhide kernel. Try
updating to the latest kernel and see if it still happens...
Comment 12 Riku Seppala 2007-10-11 16:11:39 EDT
Freezes with 2.6.23-5.fc8 just by running /sbin/hwclock as root. Even without
the --systohc
Comment 13 Chuck Ebbert 2007-10-11 16:18:33 EDT
What does "hwclock --show --debug" do?
Comment 14 Riku Seppala 2007-10-11 16:33:27 EDT
hwclock from util-linux-ng 2.13
using /dev interface to clock.

And then freeze.
Comment 15 Riku Seppala 2007-11-26 11:15:22 EST
I'm using rawhide now, last line  when running "hwclock --show --debug" before

/dev/rtc does not have interrupt functions. waiting in loop for time from
/dev/rtc to change
Comment 16 Riku Seppala 2007-12-09 16:18:21 EST
kernel 2.6.24-0.79.rc4.git5.fc9

[root@localhost ~]# hwclock --show --debug
hwclock from util-linux-ng 2.13
hwclock: Open of /dev/rtc failed, errno=19: No such device.
No usable clock interface found.
Cannot access the Hardware Clock via any known method.
[root@localhost ~]#

Don't know if it matters anything, but this is f8 and right now I only updated
kernel from rawhide and nothing else yet.
Comment 17 Riku Seppala 2008-02-06 10:57:04 EST
F9 alpha: immediate freeze when running hwclock, except it worked at least once.
Comment 18 Riku Seppala 2008-02-06 12:56:32 EST
Just noticed, this is duplicate of 227234 ? I'll close this.

*** This bug has been marked as a duplicate of 227234 ***

Note You need to log in before you can comment on or make changes to this bug.