Bug 322591 - Trouble installing fedora 8 test 3
Trouble installing fedora 8 test 3
Status: CLOSED CANTFIX
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
i386 Linux
low Severity high
: ---
: ---
Assigned To: Anaconda Maintenance Team
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-07 20:28 EDT by hal
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 09:36:49 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description hal 2007-10-07 20:28:44 EDT
Description of problem: Unable to smoothly install fedora 8 test 3 on a Dell
Inspiron 5000 laptop.  First attempt failed while formatting partitions.  Second
attempt seemed to work but with error dialogs, and grub no longer showed the
other (windows) partition after the install.


Version-Release number of selected component (if applicable): Fedora 8 test 3
live x386 CD (7.92)


How reproducible: Not clear; failed unexpectedly in different ways on two
successive attempts


Steps to Reproduce:
1.  Boot from fedora 8 live CD
2.  Double click install icon to install
3.
  
Actual results:

First try: Computer froze at the point it was formatting the disks.  The last
dialog on the screen seemed to show it was formatting the / partition.

Second try:  The install seemed to work, but as it was starting to copy the live
image to disk, a dialog box appeared with the message (paraphrased) "cannot
mount volume /boot; Error org.freedesktop.Hal.Device.InterfaceLocked".  In spite
of this the data still was copied to the hard disk, and the I was able to reboot
into fedora after the install finished.  But: this is a dual-boot machine and
after installing the test3 live CD, grub only showed the fedora partition in
it's list.  (The windows partition is most likely still there, since the fedora
install only used as much of the disk as the fedora 7 system it was replacing,
but I haven't verified that yet.)


Expected results:  Normal install, with both fedora and windows partitions
available as selections in grub.


Additional info:
Comment 1 Jeremy Katz 2007-10-09 11:51:02 EDT
The dialog and vista not being set up in the bootloader are being tracked in
separate bugs.

When it failed while formatting, did the machine reboot, hard hang, or give a
traeback?
Comment 2 hal 2007-10-09 15:23:18 EDT
The freeze while formatting was a hard hang - no reboot, traceback, or anything else.  I had to power-
cycle the machine manually to recover.

(And on the other bug, the boot partition is XP, not vista, but it's probably the same issue either way.  I did 
confirm that the XP partition was intact in spite of not showing up in the boot menu.)
Comment 3 hal 2007-10-09 15:24:34 EDT
Sorry, that should be "the other partition is XP", not "the boot partition is XP".  Either way, it's still there.
Comment 4 Jeremy Katz 2007-10-09 15:54:01 EDT
The freeze is probably kernel related -- how much RAM do you have in your system?
Comment 5 hal 2007-10-10 00:33:48 EDT
384MB - not huge, but well above the fedora 8 minimum, I think.  Other hardware includes a 650MHz 
pentium III and about 11GB of available disk space for the fedora partitions.
Comment 6 Jeremy Katz 2007-10-10 09:36:49 EDT
I suspect that you were just running out of memory.  The live image keeps all
changes to the system in a RAM-based overlay -- helpful, as you can then have a
read/write filesystem.  Unfortunate as it takes up memory.  And especially as
you're running without swap (as we need to be able to entirely repartition), the
memory requirements will often be a little bit higher.

The second time probably worked as you had done less on the system before
kicking off the installation.
Comment 7 hal 2007-10-10 16:48:56 EDT
I'm sure that's possible, but if so, there's very little headroom.  The first
time around, I probably didn't do much more before attempting to install than
launch firefox to see if I had a live net connection.  The second time I did run
the installer as the first thing after the boot.

Not sure what to suggest other than it would be better if it could fail more
gracefully, or maybe abandon the existing changes in RAM with the user's
permission if they're only using the live CD to do an installation.

(For an old machine like this, I'd actually be happy if there were a way to just
run an installer from a CD without necessarily starting a live image. 
Unfortunately, this machine has trouble booting from a >2GB disk, so I haven't
been able to successfully use the DVD image to install.)

Note You need to log in before you can comment on or make changes to this bug.