Bug 32260 - i810 vs Xfree: Not enough memory for dma buffers
Summary: i810 vs Xfree: Not enough memory for dma buffers
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: XFree86   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Mike A. Harris
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-19 18:48 UTC by D. Hugh Redelmeier
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-04-30 21:49:21 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
XF86Config (15.85 KB, text/plain)
2001-03-22 20:48 UTC, D. Hugh Redelmeier
no flags Details
log saved by script(1) of startx; 2.2.17-14 system was booted with mem=56M (8.14 KB, text/plain)
2001-03-22 20:52 UTC, D. Hugh Redelmeier
no flags Details
dmesg output -- indicates hardware configuration (4.01 KB, text/plain)
2001-03-22 20:56 UTC, D. Hugh Redelmeier
no flags Details

Description D. Hugh Redelmeier 2001-03-19 18:48:04 UTC
startx fails on Intel 810 system with message
	(EE) I810(0): Not enough memory for dma buffers

Motherboard is MSI 6183 version 1 (not 6183E) with 64M of RAM.
System is full RHL7 install, with updates as of end of 2001 February.

- tried to boot with "mem=56m", but made no difference
- tried with both 2.2.17-14 and 2.2.16-22 kernels -- no difference.

From a 2.2.17-14 kernel boot:
	Linux agpgart interface v0.99 (c) Jeff Hartmann
	agpgart: Maximum main memory to use for agp memory: 22M
	agpgart: Detected an Intel i810 DC100 Chipset.
	agpgart: detected 4MB dedicated video ram.
	agpgart: AGP aperture is 64M @ 0xe8000000
From a startx log:
	(--) I810(0): Chipset: "i810-dc100"
	(--) I810(0): Linear framebuffer at 0xE8000000
	(--) I810(0): IO registers at addr 0xEFF80000
	(**) I810(0): Will alloc AGP framebuffer: 4096 kByte
 ...
	(0): [drm] loaded kernel module "i810"
	(0): [drm] created "i810" driver at busid "PCI:0:1:0"
	(0): [drm] added 4096 byte SAREA at 0xc0617000
	(0): [drm] mapped SAREA 0xc0617000 to 0x40017000
	(0): [drm] framebuffer handle = 0xe8000000
	(0): [drm] added 1 reserved context for kernel
	(II) I810(0): [drm] Registers = 0xeff80000
	(II) I810(0): dcacheHandle : 0xc4306000
	(II) I810(0): GART: Found 4096K Z buffer memory
	(II) I810(0): Bound backbuffer memory
	(II) I810(0): GART: Allocated 4K for mouse cursor image
	(II) I810(0): Allocated Scratch Memory
	(II) I810(0): Buffer map : 0
	(EE) I810(0): Not enough memory for dma buffers
	(0): [drm] failed to remove DRM signal handler

	Fatal server error:

I have more log info saved, but it seems too large for this margin.

Comment 1 D. Hugh Redelmeier 2001-03-19 19:12:00 UTC
I forgot to mention that 
	http://www.redhat.com/support/docs/tips/i810.html
is interesting, but out of date.  Xfree4 is different from Xfree3 and the
kernels has advanced in 810 support too.  But I think that there still are
issues with 810 support, so a new version would be welcome.

Comment 2 Mike A. Harris 2001-03-22 20:17:52 UTC
In order to look into this problem I require a full copy of your XFree86
config file, and a full X server log.  Please attach them using the file
attach link below.

Comment 3 D. Hugh Redelmeier 2001-03-22 20:48:41 UTC
Created attachment 13384 [details]
XF86Config

Comment 4 D. Hugh Redelmeier 2001-03-22 20:52:17 UTC
Created attachment 13385 [details]
log saved by script(1) of startx; 2.2.17-14 system was booted with mem=56M

Comment 5 D. Hugh Redelmeier 2001-03-22 20:56:44 UTC
Created attachment 13386 [details]
dmesg output -- indicates hardware configuration

Comment 6 D. Hugh Redelmeier 2001-04-30 21:49:16 UTC
I just did an upgrade-install to RHL7.1.  startx works just fine.  Still no idea
what the problem was, but it looks like I'm not going to be the one to figure it
out.

Comment 7 Mike A. Harris 2001-06-12 06:48:54 UTC
Ok glad to hear it works for you.  Also, there are some other known
problems with the 7.1 X server that have been fixed in 4.0.3-21, and
will be released on my ftp space shortly:

ftp://people.redhat.com/mharris/testing


Note You need to log in before you can comment on or make changes to this bug.