Bug 323 - mouseconfig does not provide a way to configure "logim" type mice
Summary: mouseconfig does not provide a way to configure "logim" type mice
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: mouseconfig   
(Show other bugs)
Version: 5.2
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Preston Brown
QA Contact:
URL:
Whiteboard:
Keywords:
: 322 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 1998-12-07 01:57 UTC by Adam Thompson
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 1999-02-10 22:00:42 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Adam Thompson 1998-12-07 01:57:04 UTC
Mouseconfig does not have any entries that correspond to
the "logim" gpm mousetype.  This makes setting up an older
logitech mouse (see bug #322) VERY difficult for anyone not
familiar with /etc/sysconfig/mouseconfig.

Under certain boot conditions, type "mman" does NOT work
with CC-series Logitech mice - type "logim" is required to
correctly initialize the device.  After gpm has
reinitialized the device, X works OK with a "MouseMan"
mouse type.

However, manual editing of /etc/sysconfig/mouseconfig is
necessary to ensure correct operation.

The case where type "mman" does not work is generally after
the mouse has been initialized by a DOS mouse driver, then
soft-booting into Linux without resetting the mouse.  Some
versions of the DOS driver initialize the mouse to use an
alternate bps rate, or an alternate packet format for use
with older, non-MOUSE.COM compliant apps.  (ie. GemWorks,
AutoCAD, etc.)

Comment 1 David Lawrence 1998-12-07 19:43:59 UTC
This has been assigned to a developer for further review.

Comment 2 David Lawrence 1998-12-07 19:44:59 UTC
*** Bug 322 has been marked as a duplicate of this bug. ***

Comment 3 Preston Brown 1999-02-10 22:00:59 UTC
will be fixed in rawhide by tomorrow.


Note You need to log in before you can comment on or make changes to this bug.