Bug 32302 - i815 X Server won't start after install
i815 X Server won't start after install
Status: CLOSED ERRATA
Product: Red Hat Linux
Classification: Retired
Component: XFree86-Servers (Show other bugs)
7.1
i386 Linux
medium Severity high
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-19 16:40 EST by Dave
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-27 15:05:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Dave 2001-03-19 16:40:23 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


X Server config and test works fine during install, but after regular boot 
it won't come up. Screen flashs and init eventually turns off re-spawn. 
Log file says 'pcidata' is missing.

Reproducible: Always
Steps to Reproduce:
1.install linux beta
2.boot to linux
3.
	

Actual Results:  see problem desc. X server will not start.

Expected Results:  Graphical login should be displayed.

Intel 815EAA motherboard, 800EB CPU, 512MB PC133 ram. Nothing else special.
Comment 1 Mike A. Harris 2001-03-19 17:29:26 EST
Please upgrade to the latest version of XFree86 from:

ftp://people.redhat.com/mharris

Version 4.0.3-2 is current.  You will also need to update Mesa and possibly
update to the latest rawhide kernel.  If the problem persists, please
provide your XFree86 server logs and XF86Config-4 cofnig files using the
attachment link below.  Also give me a copy of the output of
both "lspci -v" and also "lspci -vn".

Also, if you are reporting against XFree86 4.x, please change it from
XFree86-Servers to just XFree86 as this bug is currently filed against the
XFree86-Servers-3.3.6 package, and I'm assuming you're using 4.x.

Thanks,
TTYL
Comment 2 Mike A. Harris 2001-03-19 18:01:14 EST
Oops, I meant 4.0.3-1  ;o)

I'm working on 4.0.3-2 right now though..
Comment 3 Preston Brown 2001-03-20 17:32:44 EST
*** Bug 32338 has been marked as a duplicate of this bug. ***
Comment 4 Abel Hernandez Zanatta 2001-03-22 10:08:33 EST
I have a similar problem, I can start the Xserver but if I use 16 or 24 bit
resolution the screen glitches every 2 seconds, please take a look at bug 32338.

I'm using 4.0.3-1 and kernel 2.4.2-0.1.25
Comment 5 Mike A. Harris 2001-03-27 15:05:34 EST
To the original poster - please supply the information that I requested so
that I can look into these problems for you.
Comment 6 Mike A. Harris 2001-05-24 16:07:12 EDT
It appears the i810 X server did not support i815.  This has been fixed in
XFree86-Servers-3.3.6-38, and an errata release will be issued shortly.

You can obtain new packages in the mean time from:
ftp://people.redhat.com/mharris/testing/7.1

Note You need to log in before you can comment on or make changes to this bug.