Bug 323121 - procinfo displays nothing and SEGV's
procinfo displays nothing and SEGV's
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: procinfo (Show other bugs)
7
x86_64 Linux
low Severity low
: ---
: ---
Assigned To: Tomas Smetana
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 10:08 EDT by James Antill
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version: 18-21.fc7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-24 03:04:02 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description James Antill 2007-10-08 10:08:35 EDT
Description of problem:
% procinfo
[1]    1433 segmentation fault  procinfo
%

Version-Release number of selected component (if applicable):
procinfo(0:18-20.fc7).x86_64


How reproducible:
 Always

Additional info:
 This is the end of an ltrace:

fgets("", 6331136, 0x60b2f0)                     = 0x609b00
strchr("2296:        124  291768847   PC"..., ':') = ":        124  291768847  
PCI-MS"...
strtok("2296:        124  291768847   PC"..., ":") = "2296"
__strtol_internal("2296", NULL, 10)              = 2296
strtok(NULL, "\n")                               = "        124  291768847  
PCI-MSI"...
strstr("291768847   PCI-MSI-edge      et"..., "PIC") = NULL
--- SIGSEGV (Segmentation fault) ---
+++ killed by SIGSEGV +++

 strace says last open was for:

open("/proc/meminfo", O_RDONLY)         = 6
Comment 1 Tomas Smetana 2007-10-09 02:57:49 EDT
Procinfo has its last update in 2001.  It must have never worked since the
64-bit machines are around.  Thanks for reporting.
Comment 2 Tomas Smetana 2007-10-11 04:41:23 EDT
There were more ways to segfault and it was also quite easy to make procinfo
divide by zero.
Comment 3 Fedora Update System 2007-10-11 18:54:16 EDT
procinfo-18-21.fc7 has been pushed to the Fedora 7 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update procinfo'
Comment 4 Fedora Update System 2007-10-24 03:04:01 EDT
procinfo-18-21.fc7 has been pushed to the Fedora 7 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.