Bug 323521 - portmap missing!
portmap missing!
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: portmap (Show other bugs)
7
All Linux
low Severity high
: ---
: ---
Assigned To: Steve Dickson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 14:28 EDT by Thomas Schweikle
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 06:47:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Thomas Schweikle 2007-10-08 14:28:38 EDT
Description of problem:
Installing nfsserver does not install portmap or an other daemon with the 
same functionality.

Version-Release number of selected component (if applicable):


How reproducible:
All times

Steps to Reproduce:
1. Install Fedora 7 CD, or DVD, then select ftp and continue to install 
from a server within the internet.
2. Install nfsserver using "yum install nfsserver"
3. Update to the latest available patches using "yum update"
  
Actual results:
nfsserver is installed, but portmap is missing. Trying to mount an 
exported directory will fail. Within the logs you may find something like 
"server xyz not reachable".

If you are looking for a running "portmap" there is none.
If you are looking for an installable package "portmap" there is none.


Expected results:
portmap (or something similar) being installed as a dependency to 
nfsserver, started before nfsd being started.

portmap within Fedora 7 packages!


Additional info:
It seems "portmap" was available some time ago, but it being removed by 
one of the updates since 1st October. Maybe there is a better alternative, 
but this isn't configured automatically...

Bad side effect: nfs mounts and exports will not work anymore!
Comment 1 Kostas Georgiou 2007-10-08 19:48:24 EDT
portmap has been renamed to rpcbind some time ago. nfs-utils depends on it so it
shoul dbe installed already in your system. You might have to enable it to run
at startup though.
Comment 2 Thomas Schweikle 2007-10-09 06:47:16 EDT
Uhh. My fault.

Note You need to log in before you can comment on or make changes to this bug.