Bug 323561 - guest networking doesn't work
guest networking doesn't work
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: libvirt (Show other bugs)
rawhide
All Linux
low Severity high
: ---
: ---
Assigned To: Daniel Veillard
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 14:52 EDT by Andy Grover
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 20:50:06 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
virt-manager.log (2.38 KB, text/plain)
2007-10-08 18:19 EDT, Andy Grover
no flags Details
output from virsh dumpxml winxp (1.08 KB, text/xml)
2007-10-08 18:20 EDT, Andy Grover
no flags Details
xend.log (220.59 KB, text/plain)
2007-10-08 18:24 EDT, Andy Grover
no flags Details

  None (edit)
Description Andy Grover 2007-10-08 14:52:44 EDT
Description of problem:
Installed WinXP and Windows 2003. Cannot obtain IP address. I think this is why:

From xentop:
Net0 RX:        0bytes        0pkts        0err       32drop  TX:        0bytes
       0pkts        0err        0drop

I think this is a fairly recent regression.
Comment 1 Daniel Berrange 2007-10-08 16:10:59 EDT
This tells us nothing, except that xentop has no stats. Please provide some
useful info.

- Guest config file 
- Logs from installation (ie /root/.virtinst/virt-install.log or 
/root/.virt-manager/virt-manager.log)
- What version of Xen RPMs you are using
- What version of libvirt you are using
- The XenD log file /var/log/xen/xend.log
- What version of Windows guest install media
- What architecture you are using in host and guest.
- Output from 'virsh dumpxml <guest'
- The host networking info (ie output of ifconfig -a, brctl show, and iptables
-L -n -v)
Comment 2 Andy Grover 2007-10-08 18:18:06 EDT
- Guest config file 
attaching dumpxml below

- Logs from installation (ie /root/.virtinst/virt-install.log or 
/root/.virt-manager/virt-manager.log)
attached

- What version of Xen RPMs you are using
xen-3.1.0-10.fc8
kernel-xen-2.6.21-2947.fc8
xen-libs-3.1.0-10.fc8

- What version of libvirt you are using
libvirt-0.3.3-1.fc8

- The XenD log file /var/log/xen/xend.log
- What version of Windows guest install media
winxp_sp2 and srv_2003_r2_std.isos

- What architecture you are using in host and guest.
i386 32b VT host, 32b guest

- Output from 'virsh dumpxml <guest'
attached

- The host networking info (ie output of ifconfig -a, brctl show, and iptables
-L -n -v)

ifconfig -a:
[root@lute ~]# ifconfig -a
eth0      Link encap:Ethernet  HWaddr 00:1A:A0:CE:62:2F  
          inet addr:192.168.1.141  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:869 errors:0 dropped:0 overruns:0 frame:0
          TX packets:743 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:649559 (634.3 KiB)  TX bytes:103113 (100.6 KiB)
          Interrupt:16 

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:16436  Metric:1
          RX packets:31322 errors:0 dropped:0 overruns:0 frame:0
          TX packets:31322 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:46363466 (44.2 MiB)  TX bytes:46363466 (44.2 MiB)

tap0      Link encap:Ethernet  HWaddr CE:3E:2E:0A:5E:01  
          inet6 addr: fe80::cc3e:2eff:fe0a:5e01/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:47 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:500 
          RX bytes:8229 (8.0 KiB)  TX bytes:468 (468.0 b)

tmpbridge Link encap:Ethernet  HWaddr 00:00:00:00:00:00  
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:6 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:0 (0.0 b)  TX bytes:468 (468.0 b)

vif1.0    Link encap:Ethernet  HWaddr FE:FF:FF:FF:FF:FF  
          inet6 addr: fe80::fcff:ffff:feff:ffff/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:53 overruns:0 carrier:0
          collisions:0 txqueuelen:32 
          RX bytes:0 (0.0 b)  TX bytes:0 (0.0 b)

virbr0    Link encap:Ethernet  HWaddr CE:3E:2E:0A:5E:01  
          inet addr:192.168.122.1  Bcast:192.168.122.255  Mask:255.255.255.0
          inet6 addr: fe80::200:ff:fe00:0/64 Scope:Link
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:47 errors:0 dropped:0 overruns:0 frame:0
          TX packets:23 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:0 
          RX bytes:7559 (7.3 KiB)  TX bytes:3805 (3.7 KiB)

brctl:
[root@lute ~]# brctl show
bridge name     bridge id               STP enabled     interfaces
tmpbridge               8000.000000000000       no
virbr0          8000.ce3e2e0a5e01       no              tap0
                                                        vif1.0

iptables:
[root@lute ~]# iptables -L -n -v
Chain INPUT (policy ACCEPT 33031 packets, 46M bytes)
 pkts bytes target     prot opt in     out     source               destination
        
    0     0 ACCEPT     udp  --  virbr0 *       0.0.0.0/0            0.0.0.0/0  
        udp dpt:53 
    0     0 ACCEPT     tcp  --  virbr0 *       0.0.0.0/0            0.0.0.0/0  
        tcp dpt:53 
   12  3960 ACCEPT     udp  --  virbr0 *       0.0.0.0/0            0.0.0.0/0  
        udp dpt:67 
    0     0 ACCEPT     tcp  --  virbr0 *       0.0.0.0/0            0.0.0.0/0  
        tcp dpt:67 

Chain FORWARD (policy ACCEPT 0 packets, 0 bytes)
 pkts bytes target     prot opt in     out     source               destination
        
    0     0 ACCEPT     all  --  *      virbr0  0.0.0.0/0           
192.168.122.0/24    state RELATED,ESTABLISHED 
    0     0 ACCEPT     all  --  virbr0 *       192.168.122.0/24     0.0.0.0/0  
        
   44  7421 ACCEPT     all  --  virbr0 virbr0  0.0.0.0/0            0.0.0.0/0  
        
    0     0 REJECT     all  --  *      virbr0  0.0.0.0/0            0.0.0.0/0  
        reject-with icmp-port-unreachable 
    0     0 REJECT     all  --  virbr0 *       0.0.0.0/0            0.0.0.0/0  
        reject-with icmp-port-unreachable 

Chain OUTPUT (policy ACCEPT 32913 packets, 45M bytes)
 pkts bytes target     prot opt in     out     source               destination
Comment 3 Andy Grover 2007-10-08 18:19:03 EDT
Created attachment 220241 [details]
virt-manager.log
Comment 4 Andy Grover 2007-10-08 18:20:02 EDT
Created attachment 220251 [details]
output from virsh dumpxml winxp
Comment 5 Andy Grover 2007-10-08 18:24:36 EDT
Created attachment 220261 [details]
xend.log

relevant stuff at end
Comment 6 Daniel Berrange 2007-10-09 21:38:35 EDT
Ok, so the guest is being connected to virbr0. This appears  to have worked ok,
since the guest is actually running. The iptables FORWARD rules don't see the
level of traffic I'd expect though. Can you run 'sysctl -a | grep
net.ipv4.ip_forward'. If it is set to '0', then best option is to edit
/etc/sysctl.conf, change it to 1 and run 'sysctl -p' & re-attempt DHCP /network
traffic in the guest
Comment 7 Andy Grover 2007-10-10 14:24:57 EDT
ip_forward was 0. I set it to 1, rebooted host/guest but guest still shows 52
pkts sent and 0 received.
Comment 8 Andy Grover 2007-10-11 20:50:06 EDT
conflict with some vpn hacks, notabug, apologies.

Note You need to log in before you can comment on or make changes to this bug.