Bug 32357 - new rpm-4.0.2 causes up2date/gnorpm to fail
new rpm-4.0.2 causes up2date/gnorpm to fail
Status: CLOSED DUPLICATE of bug 32301
Product: Red Hat Linux
Classification: Retired
Component: rpm (Show other bugs)
6.2
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeff Johnson
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-19 21:58 EST by Need Real Name
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-19 21:59:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Need Real Name 2001-03-19 21:58:54 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.72 [en] (X11; U; Linux 2.4.1 i686)


I used up2date to download and install the new version of rpm as
suggested.  The installer correctly downloaded and installed the rpms for
rpm.  When I run rpm or gnorpm again, I get the error:
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/librpm.so.0: undefined symbol: fdio
I was able to run rpm --rebuild as suggested on the 6.2 bug fix page for
the new rpm package but rpm still does not work.

Reproducible: Always
Steps to Reproduce:
1. Upgrade a 6.2 box to the new rpm
2. Try to run gnorpm or up2date
3. Get an error...
	

Actual Results:  trying to run up2date I get:
Traceback (innermost last):
  File "/usr/sbin/up2date", line 9, in ?
    import rpm
ImportError: /usr/lib/librpm.so.0: undefined symbol: fdio

trying to run gnorpm I get:
gnorpm: error in loading shared libraries: /usr/lib/librpm.so.0: undefined
symbol: fdio

Expected Results:  Instead of getting an error the two applications up2date
and gnorpm should have started normally.

I feel that this is a bug since I downloaded the new rpm's directly from
the RedHat website and up2date and gnorpm now cease to work.  I assume it
is some sort of library dependency that wasn't taken into account.
Comment 1 Bill Nottingham 2001-03-19 22:04:22 EST

*** This bug has been marked as a duplicate of 32301 ***

Note You need to log in before you can comment on or make changes to this bug.