Bug 323661 - revisor doesn't parse kickstart reboot command properly
revisor doesn't parse kickstart reboot command properly
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: revisor (Show other bugs)
7
All Linux
low Severity medium
: ---
: ---
Assigned To: Jonathan Steffan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 15:51 EDT by Vadym Chepkov
Modified: 2007-11-30 17:12 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-10 20:03:08 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Vadym Chepkov 2007-10-08 15:51:41 EDT
Description of problem:

When you create an image with your own kickstart file that contain command
'reboot --eject' and choose option to write kickstart file on the image revisor
produces wrong output:

# Reboot after installation
reboot
 --eject# System services

The command got split in two rows and produces wrong kickstart file

Version-Release number of selected component (if applicable):
revisor-2.0.4.1-2.fc7
Comment 1 Jonathan Steffan 2007-10-09 03:28:56 EDT
Strange. We use pykickstart to write out the kickstart into the tree the image
is composed from. Thanks for the report, we'll look into it.

Do you know what version of pykickstart you are using?
Comment 2 Vadym Chepkov 2007-10-09 07:51:53 EDT
It's pykickstart-1.1.1-1.fc7
Comment 3 Vadym Chepkov 2007-10-10 10:59:31 EDT
I have discovered another issue and I am not sure if I need to open another
ticket, but here is another command that is not getting parsed properly:

Source command:
part pv.1 --size=0 --grow --ondisk=sda --asprimary

After parsing, wrong one, since size has to be specified:
part pv.1 --asprimary --grow --ondisk=sda --bytes-per-inode=4096

Is there any reason why kickstart file is getting re-writen anyway, why not just
copy it as is ?
Comment 4 Jonathan Steffan 2007-11-10 20:03:08 EST
Kickstart is now copied.

Note You need to log in before you can comment on or make changes to this bug.