Bug 323671 - NetworkManager-vpnc fails to connect
NetworkManager-vpnc fails to connect
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: NetworkManager-vpnc (Show other bugs)
rawhide
All Linux
low Severity low
: ---
: ---
Assigned To: Denis Leroy
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Target
  Show dependency treegraph
 
Reported: 2007-10-08 16:01 EDT by Will Woods
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-11 12:35:53 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Will Woods 2007-10-08 16:01:23 EDT
NetworkManager-vpnc snapshot svn2914 never manages to make a vpn connection.
I've confirmed that it works if you run vpnc directly.

/var/log/messages has the following to say:
Oct  8 15:51:36 albook NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' exec scheduled...
Oct  8 15:51:36 albook NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' executed
(org.freedesktop.NetworkManager.vpnc), PID 2768
Oct  8 15:51:36 albook kernel: tun: Universal TUN/TAP device driver, 1.6
Oct  8 15:51:36 albook kernel: tun: (C) 1999-2004 Max Krasnyansky
<maxk@qualcomm.com>
Oct  8 15:51:36 albook NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
Oct  8 15:51:36 albook NetworkManager: <info>  VPN service
'org.freedesktop.NetworkManager.vpnc' just appeared, activating connections
Oct  8 15:51:36 albook NetworkManager: nm_vpn_connection_activate: assertion
`nm_vpn_connection_get_state (connection) == NM_VPN_CONNECTION_STATE_PREPARE' failed

After a minute or so, this times out and I get the prompt window for the vpn
info. I fill that in and nothing happens. Here's the relevant log info:

Oct  8 15:52:32 albook NetworkManager: <info>  VPN connection 'RDU' (Connect)
reply received.
Oct  8 15:52:32 albook NetworkManager: <WARN>  connection_state_changed(): Could
not process the request because no VPN connection was active.

Further attempts to bring up the VPN fail immediately with the above two log
messages.
Comment 1 Christopher Aillon 2007-10-11 12:35:53 EDT
Fixed by svn2970.

Note You need to log in before you can comment on or make changes to this bug.