Bug 323771 - no sound when playing media with realplayer
no sound when playing media with realplayer
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: kernel (Show other bugs)
5.1
All Linux
low Severity high
: ---
: ---
Assigned To: Brian Maly
Martin Jenner
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 16:38 EDT by Cameron Meadors
Modified: 2007-11-30 17:07 EST (History)
3 users (show)

See Also:
Fixed In Version: RHBA-2007-0959
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-11-07 15:05:37 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Cameron Meadors 2007-10-08 16:38:27 EDT
Description of problem:

When I play a stream or file with Realplayer I do not get any sound.

Version-Release number of selected component (if applicable):

RealPlayer-10.0.9-3.el5
alsa-lib-1.0.14-1.rc4.el5
kernel-2.6.18-51.el5

How reproducible:

Always

Steps to Reproduce:
1. Go to a website that has Real content
2. Play the content
3.
  
Actual results:

Video plays with not sound.  There are no errors.

Expected results:

Video with sound

Additional info:

It looks like /dev/dsp does not exist.  lsof shows that realplayer never opens a
sound device.
Comment 1 Jonathan Blandford 2007-10-09 10:18:53 EDT
If /dev/dsp doesn't exist, this is more likely to be a udev or kernel bug. 
Certainly not a RealPlayer bug, anyway
Comment 2 Tim Burke 2007-10-09 10:29:54 EDT
followup info requested:
- did this work in RHEL5GA (ie, is it a regression)
- what hardware does this work on and what does it fail on
- does sound work on those boxes for other apps?
Comment 3 Tim Burke 2007-10-09 10:32:43 EDT
RHEL5 daily release readiness discussion:
Unsure if this is really a blocker.  Can't tell yet due to needed info.  Ongoing
investigation needed. Followup promised by QE, jrb, pgraner.
Comment 4 Pete Graner 2007-10-09 11:37:14 EDT
Had a conf call with the Desktop (alsa) team, udev maintainer, current thoughts
are that udev is not at fault and the issue lies in asla/kernel.

RHEL5 GA has /dev/dsp as confirmed by kreilly
Comment 5 Pete Graner 2007-10-09 11:39:01 EDT
jrb is following up with alsa maintainer
Comment 6 Martin Stransky 2007-10-09 12:11:54 EDT
/dev/dsp and /dev/adsp are created by snd_pcm_oss module, you can load/unload it
and see if there the devices are present. 

That issue is not related to ALSA user-space packages, /dev/ entries are created
w/o them and the udev rules there are used only for restoring a volume.
Comment 7 Cameron Meadors 2007-10-09 12:56:12 EDT
Unloading and reloading snd_pcm_oss produces this error four times:

  device_create does not work yet for NULL parents

Of course, still no devices. Creating the devices by hand does not work.  Not
that I expected it to.
Comment 8 Jonathan Blandford 2007-10-09 13:34:59 EDT
Reassigning.
Comment 9 John Feeney 2007-10-09 15:31:37 EDT
I'm following the reported error with device_create(). It looks to me 
as though the large alsa patch switched from class_device_create() to
device_create() while still passing a NULL as the value to the parent
argument. Well, that works with class_device_create() but not with
device_create(). Upstream I see where device_create() no longer checks
for a NULL parent so the patch may work if RHEL5.1 had the same code.
I'm checking this now. 
See 
http://git.kernel.org/?p=linux/kernel/git/torvalds/linux-2.6.git;a=commitdiff;h=64bb5d2c116478dba7501d2acf078ed74ba30c1f
Comment 10 John Feeney 2007-10-09 15:43:32 EDT
After applying the upstream patch, building, and rebooting, I have a /dev/dsp
and there is no "device_create does not work yet for NULL parents" message.
Comment 11 John Feeney 2007-10-09 16:36:20 EDT
Brian tested the patch with RealPlayer and it worked.
Comment 15 Don Zickus 2007-10-11 11:14:34 EDT
in 2.6.18-53.el5
You can download this test kernel from http://people.redhat.com/dzickus/el5
Comment 18 errata-xmlrpc 2007-11-07 15:05:37 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2007-0959.html

Note You need to log in before you can comment on or make changes to this bug.