Bug 32382 - suspend messes up XFree86(NM2200, Redhat certified!), (old) XF86_SVGA works ok
suspend messes up XFree86(NM2200, Redhat certified!), (old) XF86_SVGA works ok
Status: CLOSED WONTFIX
Product: Red Hat Linux
Classification: Retired
Component: XFree86 (Show other bugs)
7.1
i386 Linux
low Severity medium
: ---
: ---
Assigned To: Mike A. Harris
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-20 04:51 EST by rosa
Modified: 2007-03-26 23:42 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-05-06 16:56:37 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description rosa 2001-03-20 04:51:19 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.2-0.1.25 i686)


After upgrading to rh 7.0, and now in the 7.0.91 beta as well (both times a
fresh install on a free partition) the display stays black when  resuming
from suspend. It used to be ok in rh 6.2.
Everything else works fine, so I can login over the network,
kill the X server and sometimes kbd_mode -a will allow me to 
continue work. Sometimes the console stays garbled and a reboot is needed.

Reproducible: Always
Steps to Reproduce:
1. reboot
2. startx (I don't run gdm)
3. apm -s || close lid || Fn + F4
4. Fn || open lid
(now X desktop used to show up again, but with 7.0 (X 4.0+ ) display stays
black)
5. login over the network
6. kill hanging X
7. kbd_mode -a  sometimes gives control again

None of the XFree86-4.0 (from rawhide) work !
But the 6.2 XF86_SVGA (X 3.3.6) does !!

FIX:
cp /redhat6.2/usr/X11R6/bin/XF86_SVGA /usr/X11R6/bin/XF86_SVGA
mv /etc/X11/X /etc/X11/X.old 
ln -s ../../usr/X11R6/bin/XF86_SVGA /etc/X11/X
Now suspending and resuming works fine !

This is on a Thinkpad 390E which used to require a kernel rebuild
to make suspend work. But since you put CONFIG_APM_ALLOW_INTS=y
in the rh7 kernel config, suspend now works out-of-the-box, except
for this bug that is. *Everybody* installing rh7 on a thinkpad 390 
has this problem. My company has 2000+ Thinkpads so go figure. 
I suggest you change the 100% compatible mark for the Neomagic 
NM2200 in your hardware list.
Comment 1 Mike A. Harris 2001-03-21 20:24:29 EST
Please try XFree86-4.0.3-1 and Mesa 3.4-13 from:

ftp://people.redhat.com/mharris

Does this solve the problem for you?
Comment 2 rosa 2001-05-06 16:56:32 EDT
Sorry for not getting back to you on this any soooner.
No, upgrading XFree86-4.0.3-1 and Mesa 3.4-13, didn't make any difference.
Neither did 7.1.
Upgrading my laptop to another make/brand did :)

I remember one other thing that points to the neomagic driver:
Moving a maximized window slightly to and from the edge 
would reproducibly result in a blurred window. Minimizing and maximizing
would restore things to normal. The same in all windowmanagers I tested 
(windowmaker, sawfish, twm) and all versions of X I used, from 3.2 up to 4.0.2.

Anyway since I don't have the neomagic anymore I'll not be able to provide 
you any more information on this. I'm assigning this back to you mike
There are clearly still bugs but you could just as well close it untill
someone else reports it again.
Comment 3 Mike A. Harris 2001-06-01 03:45:33 EDT
Ok, closing bug - wish there was a CANTLOOKINTOIT because NOTABUG isn't right -
it is a bug, WONTFIX isn't right - we will fix it, when we have info..  ;o)


Note You need to log in before you can comment on or make changes to this bug.