Bug 323981 - device descriptor read/64, error -62, leads to printing problems
device descriptor read/64, error -62, leads to printing problems
Status: CLOSED DUPLICATE of bug 308691
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
7
i686 Linux
low Severity medium
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-08 18:29 EDT by Mumrel
Modified: 2007-11-30 17:12 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 05:21:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Mumrel 2007-10-08 18:29:20 EDT
Description of problem:
After turning the usb-printer off once, i can't print after turning it on again.
This seems to relate to those error messages.
After each reboot i can print, as long as i won't turn the printer off. 
Its a Samsung ML-1410. 
I am not sure wether this is a USB problem or a CUPS problem. But since no one
responded here https://bugzilla.redhat.com/show_bug.cgi?id=308691 i'll give it a
try.

Version-Release number of selected component (if applicable):
Common UNIX Printing System 1.2.12
Linux gleichgewicht 2.6.22.9-91.fc7 #1 SMP Thu Sep 27 23:10:59 EDT 2007 i686
athlon i386 GNU/Linux

How reproducible:
Always

Steps to Reproduce:
1. Boot fedora
2. Print something -> all ok
3. Turn off printer
4. Print again -> nothing happens, only the mentioned error messages occur
(5. Reboot to get that stuff printed)
  
Actual results:
The usb connection to the printer seems to be disrupted, 
the documents are not being printed.

Expected results:
Printer blinks (receives data) and prints the documents
i.e. or more general: the usb connection works


Additional info: dmesg
usb 1-2: USB disconnect, address 3
drivers/usb/class/usblp.c: usblp0: removed
usb 1-2: new full speed USB device using ohci_hcd and address 4
usb 1-2: device descriptor read/64, error -62
usb 1-2: device descriptor read/64, error -62
usb 1-2: new full speed USB device using ohci_hcd and address 5
usb 1-2: device descriptor read/64, error -62
usb 1-2: new full speed USB device using ohci_hcd and address 6
usb 1-2: configuration #1 chosen from 1 choice
drivers/usb/class/usblp.c: usblp0: USB Bidirectional printer dev 6 if 0 alt 0
proto 2 vid 0x04E8 pid 0x3242
Comment 1 Tim Waugh 2007-10-09 05:21:44 EDT
Looks like a kernel problem really.

*** This bug has been marked as a duplicate of 308691 ***

Note You need to log in before you can comment on or make changes to this bug.