Bug 32414 - -10 error when installing Borland Kylix with RPMs
Summary: -10 error when installing Borland Kylix with RPMs
Status: CLOSED WORKSFORME
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: rpm   
(Show other bugs)
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Jeff Johnson
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-20 17:48 UTC by Need Real Name
Modified: 2007-04-18 16:32 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 19:53:09 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Need Real Name 2001-03-20 17:48:58 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)


When installing Borland Kylix using RPMs, the install aborts with the 
error -10.  Borland reports this is a problem with RPM-4.0.2 that is 
distributed with Wolverine.  Borland reports that the error does not occur 
on RedHat 7.0 with an older version of RPM.

Borland also reports that the problem involves the handling of relocatable 
packages.

Reproducible: Always
Steps to Reproduce:
1. Install Borland Kylix as root.
2. Since the software is commercial, I can not provide a sample RPM that 
demonstrates the problem.
3. I also don't know how to create packages, so I can't create an example 
either.

Actual Results:  Error -10 occurred

Expected Results:  No error should occur

Comment 1 Jeff Johnson 2001-03-20 18:41:29 UTC
Can you supply a pointer to the package you are trying to install?

Comment 2 Need Real Name 2001-03-20 19:53:05 UTC
The package name is kylix_main_program_files-1.0-1.i386.rpm

I can not provide the package because because it is commercial software.  I 
found a reference in Borland's newsgroup 
(news://newsgroups.borland.com/borland.public.install.kylix)

Stefan Hoffmeister (Borland.Newsgroups@econos.com), a TeamB member, reported 
the error was caused by RPM 4.0.2.  I figured Borland would have contacted 
RedHat about the problem, but I guess not.  I'm just an end user of both 
products - I have no idea how to coordinate this issue.

Comment 3 Jeff Johnson 2001-03-20 20:44:10 UTC
I need to see a copy of the package in order to determine what's wrong. Please
encourage someone at Borland to reopen this bug with a pointer if they think
there's a problem with rpm-4.0.2.

Comment 4 Need Real Name 2001-04-02 11:29:19 UTC
See

  https://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=25876

which is probably the exact same issue.

Comment 5 Jeff Johnson 2001-04-02 15:00:18 UTC
Maybe it's the same as #25876, maybe not. I still need to see the
package and the command line used to install before I can diagnose
the problem.


Note You need to log in before you can comment on or make changes to this bug.