Bug 32415 - Cannot paste with middle mouse button from Nedit 5.1.1 to gnome-terminal
Cannot paste with middle mouse button from Nedit 5.1.1 to gnome-terminal
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: gnome-core (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Havoc Pennington
Ben Levenson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-20 12:51 EST by Matt
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 15:06:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Matt 2001-03-20 12:51:01 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14smp i686)


This problem is reproducible between several users and two installations of
wolverine.

Highlighting text in the editor Nedit 5.1.1 and using the middle mouse
button to paste into gnome-terminal does not work.  However, it does work
between gnome-terminal and emacs, xterm and netscape, and nedit.
Also with nedit and the above applications.

Not sure if it's an nedit, gnome-terminal, or XFree86 bug.  However, I have
tried gnome-core-1.2.4-11 and XFree86-4.0.2-12.1 from rawhide, and these
packages do not resolve the problem.

It works fine on Guiness.

Reproducible: Always
Steps to Reproduce:
1. Higlight text in nedit
2. Use middle mouse button in gnome-terminal
3. It doesn't work
	

Actual Results:  Nothing

Expected Results:  Highlighted text should appear in gnome-terminal
Comment 1 Havoc Pennington 2001-03-20 14:01:01 EST
It works for me here, I can't reproduce it with latest gnome-core and nedit
packages. Anyone else able to reproduce?
Comment 2 Matt 2001-03-20 14:16:30 EST
In light of the last comment, I tried a running a gnome-terminal from a machine
running wolverine, locally on a machine running Guinness using ssh.  Still can't
paste from any version of nedit running on any machine to this particular
gnome-terminal.

I copied the binary from the Guiness machine to the wolverine machine.  Still
the same problem.

PS : the message 'Selection retrieval failed' appears in the terminal where the
gnome-terminal is run from
Comment 3 Havoc Pennington 2001-03-20 15:06:31 EST
Maybe try the Guinness libzvt (in gnome-libs) on Wolverine, and see if that
fixes it, that'll help narrow it down.
Comment 4 Matt 2001-03-20 15:33:32 EST
On upgrading to gnome-libs-1.2.8-10 from rawhide the problem is resolved. 
Cheers!

Note You need to log in before you can comment on or make changes to this bug.