Bug 32415 - Cannot paste with middle mouse button from Nedit 5.1.1 to gnome-terminal
Summary: Cannot paste with middle mouse button from Nedit 5.1.1 to gnome-terminal
Status: CLOSED RAWHIDE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: gnome-core
Version: 7.1
Hardware: i386
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Havoc Pennington
QA Contact: Ben Levenson
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-20 17:51 UTC by Matt
Modified: 2007-04-18 16:32 UTC (History)
0 users

(edit)
Clone Of:
(edit)
Last Closed: 2001-03-20 20:06:34 UTC


Attachments (Terms of Use)

Description Matt 2001-03-20 17:51:01 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.2.17-14smp i686)


This problem is reproducible between several users and two installations of
wolverine.

Highlighting text in the editor Nedit 5.1.1 and using the middle mouse
button to paste into gnome-terminal does not work.  However, it does work
between gnome-terminal and emacs, xterm and netscape, and nedit.
Also with nedit and the above applications.

Not sure if it's an nedit, gnome-terminal, or XFree86 bug.  However, I have
tried gnome-core-1.2.4-11 and XFree86-4.0.2-12.1 from rawhide, and these
packages do not resolve the problem.

It works fine on Guiness.

Reproducible: Always
Steps to Reproduce:
1. Higlight text in nedit
2. Use middle mouse button in gnome-terminal
3. It doesn't work
	

Actual Results:  Nothing

Expected Results:  Highlighted text should appear in gnome-terminal

Comment 1 Havoc Pennington 2001-03-20 19:01:01 UTC
It works for me here, I can't reproduce it with latest gnome-core and nedit
packages. Anyone else able to reproduce?

Comment 2 Matt 2001-03-20 19:16:30 UTC
In light of the last comment, I tried a running a gnome-terminal from a machine
running wolverine, locally on a machine running Guinness using ssh.  Still can't
paste from any version of nedit running on any machine to this particular
gnome-terminal.

I copied the binary from the Guiness machine to the wolverine machine.  Still
the same problem.

PS : the message 'Selection retrieval failed' appears in the terminal where the
gnome-terminal is run from

Comment 3 Havoc Pennington 2001-03-20 20:06:31 UTC
Maybe try the Guinness libzvt (in gnome-libs) on Wolverine, and see if that
fixes it, that'll help narrow it down.

Comment 4 Matt 2001-03-20 20:33:32 UTC
On upgrading to gnome-libs-1.2.8-10 from rawhide the problem is resolved. 
Cheers!


Note You need to log in before you can comment on or make changes to this bug.