Bug 32441 - Anaconda fault that won't allow me to install Linux...
Summary: Anaconda fault that won't allow me to install Linux...
Status: CLOSED DUPLICATE of bug 18032
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: anaconda   
(Show other bugs)
Version: 7.0
Hardware: i386
OS: Linux
high
high
Target Milestone: ---
Assignee: Michael Fulbright
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-20 22:26 UTC by arcblatt
Modified: 2005-10-31 22:00 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-20 22:28:00 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Anaconda fault that won't allow installation... (1.39 KB, text/plain)
2001-03-20 22:27 UTC, arcblatt
no flags Details

Description arcblatt 2001-03-20 22:26:39 UTC
Traceback (innermost last):
  File "/usr/bin/anaconda", line 438, in ?
    intf.run(todo, test = test)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 336, in run
    self.icw.run ()
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 678, in run
    mainloop ()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 2554, in mainloop
    _gtk.gtk_main()
  File "/usr/lib/python1.5/site-packages/gtk.py", line 125, in __call__
    ret = apply(self.func, a)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 428, in 
nextClicked
    self.setScreen (self.currentScreen, self.nextClicked)
  File "/var/tmp/anaconda-7.0.1//usr/lib/anaconda/gui.py", line 466, in 
setScreen
    new_screen = screen.getScreen ()
  File "/var/tmp/anaconda-
7.0.1//usr/lib/anaconda/iw/rootpartition_gui.py", line 133, in getScreen
    avail = apply(isys.spaceAvailable, self.todo.fstab.getRootDevice())
  File "/usr/lib/anaconda/isys.py", line 10, in spaceAvailable
    mount(device, "/mnt/space", fstype = fsystem)
  File "/usr/lib/anaconda/isys.py", line 99, in mount
    rc = _isys.mount(fstype, device, location, readOnly)
SystemError: (16, 'Device or resource busy')

Local variables in innermost frame:
fstype: vfat
location: /mnt/space
devName: /tmp/hda1
readOnly: 0
device: /tmp/hda1

ToDo object:
(itodo
ToDo
p1
(dp2
S'method'
p3
(iimage
CdromInstallMethod
p4
(dp5
S'progressWindow'
p6

<failed>

Comment 1 arcblatt 2001-03-20 22:27:57 UTC
Created attachment 13183 [details]
Anaconda fault that won't allow installation...

Comment 2 Daniel Roesen 2001-03-20 23:28:48 UTC
Fixed looong ago. See: http://www.redhat.com/support/errata/RHBA-2000-084.html

*** This bug has been marked as a duplicate of 18032 ***

Comment 3 arcblatt 2001-03-21 23:11:49 UTC
Fixed looong ago?  Now it comes up with another bug that I can't even save in a 
floppy because the system crashes completely.


Note You need to log in before you can comment on or make changes to this bug.