Bug 32477 - kinit fails when using keytab
Summary: kinit fails when using keytab
Status: CLOSED DEFERRED
Alias: None
Product: Red Hat Raw Hide
Classification: Retired
Component: krb5   
(Show other bugs)
Version: 1.0
Hardware: All
OS: Linux
low
medium
Target Milestone: ---
Assignee: Nalin Dahyabhai
QA Contact: Brian Brock
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-21 00:55 UTC by Elliot Lee
Modified: 2007-03-27 03:42 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 00:55:31 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Elliot Lee 2001-03-21 00:55:28 UTC
$ kadmin -r TEST.ME -p admin/admin@TEST.ME
Authenticating as principal admin/admin@TEST.ME with password.
Enter password:
kadmin:  ktadd -k sopwith.keytab sopwith@TEST.ME
Entry for principal sopwith@TEST.ME with kvno 3, encryption type DES cbc
mode with CRC-32 added to keytab WRFILE:sopwith.keytab Entry for principal
sopwith@TEST.ME with kvno 3, encryption type Triple DES cbc mode raw added
to keytab WRFILE:sopwith.keytab
kadmin:  quit
$ kinit -k host/ath.test.me@TEST.ME
kinit(v5): Bad encryption type while getting initial credentials

--------------------
While possibly caused by operator error, the instructions available seem to
indicate that this should work. Using kinit on this same principal with the
password instead of the keytab file works fine. This happens on both Alpha
and x86 archs - the alpha is using krb5-*-1.2.2-3, the x86 krb5-*-1.2.1-8.

Comment 1 Nalin Dahyabhai 2001-06-27 05:06:55 UTC
This is a partially-implemented feature.  Currently, kinit using a keytab
only works for DES, not 3DES.  To extract just a DES key, use the
"ktadd -e des <principal>" syntax in kadmin.  I expect this will be fixed in
a future release of Kerberos 5.


Note You need to log in before you can comment on or make changes to this bug.