Bug 324851 - cups lists printers with server hostname
cups lists printers with server hostname
Status: CLOSED WORKSFORME
Product: Fedora
Classification: Fedora
Component: cups (Show other bugs)
8
i386 Linux
low Severity low
: ---
: ---
Assigned To: Tim Waugh
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 09:10 EDT by Ian
Modified: 2008-01-10 12:31 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2008-01-10 12:31:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Ian 2007-10-09 09:10:41 EDT
Description of problem: cups lists printers with server hostname

device for col@dunnet: ipp://dunnet:631/printers/col

where it should really be:

device for col: ipp://dunnet:631/printers/col


Version-Release number of selected component (if applicable):


How reproducible: Seems to happen after initial install. Cannot reproduce later.


Steps to Reproduce:
1. Install cups with default config files
2. Start cups 
3. lpstat -t
  
Actual results:
...
device for col@dunnet: ipp://dunnet:631/printers/col

Expected results:
...
device for col: ipp://dunnet:631/printers/col

Additional info: Clearing cups cache and restarting will fix the problem:

/etc/init.d/cups stop
\rm -rf /var/cache/cups
/etc/init.d/cups start

We have 2 cups servers in our subnet, which may have some effect.
Comment 1 Tim Waugh 2007-10-09 10:13:21 EDT
> We have 2 cups servers in our subnet, which may have some effect.

This is expected behaviour then.

http://localhost:631/help/ref-cupsd-conf.html#BrowseShortNames

==>
The BrowseShortNames directive specifies whether or not short names are used for
remote printers when possible. Short names are just the remote printer name,
without the server ("printer"). If more than one remote printer is detected with
the same name, the printers will have long names ("printer@server1",
"printer@server2".)

The default value for this option is Yes.
<==
Comment 2 Ian 2007-10-09 10:27:28 EDT
Not really. There is no overlap in printer names, the servers are in different
departments.  Once I've done the "fix" I can see both printer lists in their
short format.

Comment 3 Tim Waugh 2007-10-09 12:28:16 EDT
Can you get this to happen again?  I haven't seen this here with two other CUPS
servers running.

Note You need to log in before you can comment on or make changes to this bug.