Bug 324961 - Evolutuion freezes in dialog asking for the password to keychain
Evolutuion freezes in dialog asking for the password to keychain
Status: CLOSED DUPLICATE of bug 322151
Product: Fedora
Classification: Fedora
Component: gnome-keyring (Show other bugs)
8
All Linux
urgent Severity high
: ---
: ---
Assigned To: Alexander Larsson
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2007-10-09 10:45 EDT by Matěj Cepl
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-09 13:18:52 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Screenshot of the issue (439.45 KB, image/png)
2007-10-09 10:45 EDT, Matěj Cepl
no flags Details
output of running evolution in gdb (27.20 KB, text/plain)
2007-10-09 10:48 EDT, Matěj Cepl
no flags Details

  None (edit)
Description Matěj Cepl 2007-10-09 10:45:34 EDT
Description of problem:
When starting evolution it shows up partically drawn dialog "Unlock keychain"
(see attached screenshot) and then this dialog freezes and evolution is not
usable anymore.

Version-Release number of selected component (if applicable):
[matej@hubmaier ~]$ rpm -qa evolution\*
evolution-remove-duplicates-0.0.2-6.fc7
evolution-data-server-1.12.0-1.fc8
evolution-2.12.0-6.fc8
evolution-data-server-1.12.0-1.fc8
evolution-webcal-2.12.0-1.fc8
evolution-data-server-devel-1.12.0-1.fc8
evolution-debuginfo-2.12.0-6.fc8
evolution-bogofilter-0.2.0-5.fc7
evolution-data-server-debuginfo-1.12.0-1.fc8
evolution-data-server-devel-1.12.0-1.fc8
evolution-remove-duplicates-debuginfo-0.0.2-6.fc7

How reproducible:
100% (on two different computers)

Steps to Reproduce:
1.start evolution (the second time on F8; first when conversion to keychain was
done, everything was OK)
2.
3.
  
Actual results:
dialog freezes everything, the rest of Evolution would be probably working,
except that it cannot get anywhere.

Expected results:
dialog is fully drawn and after the password is entered it goes away and
Evolution works

Additional info:
Comment 1 Matěj Cepl 2007-10-09 10:45:34 EDT
Created attachment 221321 [details]
Screenshot of the issue
Comment 2 Matěj Cepl 2007-10-09 10:48:29 EDT
Created attachment 221341 [details]
output of running evolution in gdb

I tried to run evolution in gdb. This is the result -- are all debuginfo
present?
Comment 3 Matěj Cepl 2007-10-09 12:38:54 EDT
I was able to reproduce the problem with gnome-keyring-manager, so I guess it is
not Evolution's problem. Please, please, fix it, I have a tough life without Evo!
Comment 4 Nicolas Mailhot 2007-10-09 13:18:52 EDT

*** This bug has been marked as a duplicate of 322151 ***
Comment 5 Matěj Cepl 2007-10-10 09:03:05 EDT
Yes, it's all jakub's fault! After downgrading to glibc-2.6.90-15 Evolution
works again.

Note You need to log in before you can comment on or make changes to this bug.