This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 325071 - kickstart installation and multiple NICs
kickstart installation and multiple NICs
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
8
All Linux
low Severity medium
: ---
: ---
Assigned To: David Cantrell
Fedora Extras Quality Assurance
:
Depends On:
Blocks: F8Blocker
  Show dependency treegraph
 
Reported: 2007-10-09 11:35 EDT by derrien
Modified: 2007-11-30 17:12 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2007-10-10 14:47:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description derrien 2007-10-09 11:35:24 EDT
Description of problem:

We are trying an unattended installation of f8test3 (kickstart/NFS) on a Dell
Latitude D600 with two network interfaces : one wired BCM5702X (on which we try
the install), one wireless BCM4306 (disabled in the BIOS)

There are two problems :

We have in our isolinux.cfg something like :

label ks
  menu label ^Kickstart
  kernel vmlinuz
  ipappend 2
  append ksdevice=bootif ks=nfs:xxx:/kickstart/ initrd=initrd.img noipv6

But it doesn't work, we get :

                              Networking Device

You have multiple network devices on this system. Which would
you like to install through ?

eth0 : Broadcom Corporation BCM4306 802.11b/g Wireless LAN Controller
eth1 : Broadcom Corporation NetXtreme BCM5702X Gigabit Ethernet

Second problem :

If we select eth1 it doesn't work and we get in tty3
INFO : eth1 is not a wireless device

If we select eth0 : installation works on the wired interface ?!?
Comment 1 Jeremy Katz 2007-10-10 14:47:21 EDT
This is probably due to some of the horkiness around the bcm43xx module in
test3.  That should be fixed up now and I just verified that ksdevice=bootif
does the right thing on a box with multiple nics.

Note You need to log in before you can comment on or make changes to this bug.