Bug 32518 - Apache tomcat startup fails in wolverine, works in RH 7.0
Apache tomcat startup fails in wolverine, works in RH 7.0
Product: Red Hat Linux
Classification: Retired
Component: glibc (Show other bugs)
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Michael K. Johnson
Brock Organ
Depends On:
  Show dependency treegraph
Reported: 2001-03-21 01:15 EST by Harvey Modlin
Modified: 2007-04-18 12:32 EDT (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Last Closed: 2001-03-21 04:59:15 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---

Attachments (Terms of Use)

  None (edit)
Description Harvey Modlin 2001-03-21 01:15:44 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 5.5; Windows NT 5.0)

Apache tomcat is used for serving Java servlets and JSP pages. It has a 
startup.sh script. It works in RH 7.0 (including 2.2.17) But it does not 
work in Wolverine. Problem #1: Java (1.3) fails to execute. Reason: 
the "cut" command has been moved from /usr/bin to /bin. Solution: ln -
s /bin/cut /usr/bin/cut. Problem #2 (after problem #1 is solved): tomcat's 
startup.sh hangs -- it remains in a running state and burns no CPU, but 
doesn't execute to completion. Reason: I don't know. HELP! Solution: If I 
only knew...

Reproducible: Always
Steps to Reproduce:
1. Install java 1.3, apache tomcat, and $JAVA_HOME and $TOMCAT_HOME 
environment variables. Create link for /bin/cut as /usr/bin/cut.
2. Run tomcat's startup.sh

Actual Results:  Watch the startup.sh script just hang in a state of limbo.

Expected Results:  startup.sh script would run to completion and apache 
jakarta tomcat would work properly 

I wiped out hard drive, reinstalled wolverine, repeated above steps, and 
got same results.

Then I wiped out hard drive, reinstalled RH7.0, repeated above steps, and 
everything worked correctly.
Comment 1 Bill Nottingham 2001-03-21 12:51:19 EST
Run a newer glibc (2.2.2-5), and set LD_ASSUME_KERNEL=2.2.5.

Alternatively, install the i386 glibc package.

Note You need to log in before you can comment on or make changes to this bug.