Bug 32519 - pre-install directive fails to execute nominated command
pre-install directive fails to execute nominated command
Status: CLOSED NOTABUG
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-21 01:20 EST by Richard Keech
Modified: 2014-03-16 22:20 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 01:51:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Richard Keech 2001-03-21 01:20:42 EST
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


Put following line in /etc/modules.conf
   pre-install  sg  modprobe ide-scsi
I expected ide-scsi module to load when sg 
module is loaded.  Both load independently without
error when insmod called from command line.
I have used this approach to
Using modutils 2.4.2-3 as supplied with wolverine.


Reproducible: Always
Steps to Reproduce:
1. as above.
2.
3.
	

Actual Results:  There is no indication either on the command line or in
the message file
that the pre-install command is being attempted.

Expected Results:  I expect the ide-scsi module to show in the output of
lsmod after
running insmod sg.

I'm using  Sony CRX140E drive, which works fine when 
both sg and ide-scsi modules are loaded.
Comment 1 Bill Nottingham 2001-03-21 01:22:37 EST
Does it work if you change it to:

above sg ide-scsi

?
Comment 2 Richard Keech 2001-03-21 01:51:28 EST
yes,  "above sg ide-scsi" does work as expected (which, I see now, is a better
way to do it).
Comment 3 Bill Nottingham 2001-03-21 01:55:23 EST
OK. I just tried the 'pre-install' variant, and it worked here OK; with
that, and because the 'above' directive seems to work for you, I'm going
to close this as notabug.

Note You need to log in before you can comment on or make changes to this bug.