Bug 32519 - pre-install directive fails to execute nominated command
Summary: pre-install directive fails to execute nominated command
Status: CLOSED NOTABUG
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: modutils (Show other bugs)
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2001-03-21 06:20 UTC by Richard Keech
Modified: 2014-03-17 02:20 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-03-21 06:51:38 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Richard Keech 2001-03-21 06:20:42 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.76 [en] (X11; U; Linux 2.4.1-0.1.9 i686)


Put following line in /etc/modules.conf
   pre-install  sg  modprobe ide-scsi
I expected ide-scsi module to load when sg 
module is loaded.  Both load independently without
error when insmod called from command line.
I have used this approach to
Using modutils 2.4.2-3 as supplied with wolverine.


Reproducible: Always
Steps to Reproduce:
1. as above.
2.
3.
	

Actual Results:  There is no indication either on the command line or in
the message file
that the pre-install command is being attempted.

Expected Results:  I expect the ide-scsi module to show in the output of
lsmod after
running insmod sg.

I'm using  Sony CRX140E drive, which works fine when 
both sg and ide-scsi modules are loaded.

Comment 1 Bill Nottingham 2001-03-21 06:22:37 UTC
Does it work if you change it to:

above sg ide-scsi

?

Comment 2 Richard Keech 2001-03-21 06:51:28 UTC
yes,  "above sg ide-scsi" does work as expected (which, I see now, is a better
way to do it).

Comment 3 Bill Nottingham 2001-03-21 06:55:23 UTC
OK. I just tried the 'pre-install' variant, and it worked here OK; with
that, and because the 'above' directive seems to work for you, I'm going
to close this as notabug.



Note You need to log in before you can comment on or make changes to this bug.