Bug 32523 - initscript problems
initscript problems
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: autofs (Show other bugs)
7.1
i386 Linux
high Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2001-03-21 05:43 EST by Gerald Teschl
Modified: 2007-03-26 23:42 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2001-08-24 03:22:21 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Patch to make "autofs stop" behave cleanly when none were started (518 bytes, patch)
2001-08-24 03:22 EDT, Jonathan Kamens
no flags Details | Diff

  None (edit)
Description Gerald Teschl 2001-03-21 05:43:01 EST
qa3019, autofs-3.1.7-14

If autofs dies and the lock file remains there, there is no way you can
restart autofs!
Since the process is not running the returnvalue of killproc is 1 and the
lock file
does not get removed upon "stop". Hence "start" wil do nothing and exit
with 0.

I think this should be fixed! Maybe other initscripts are affected as well.
Comment 1 Jonathan Kamens 2001-08-24 03:21:08 EDT
This problem is greatly exacerbated by the recent change to autofs commenting
out the /misc entry from /etc/auto.master.  Because of this change, the default
configuration of autofs is that there are no mount points, i.e.,
/usr/sbin/automount won't be started at all when "autofs start" is run. 
Nevertheless, the lock file will get created, but then when "autofs stop" is run
later, it'll fail because there are no automount processes to kill.  This on a
properly configured system with no autofs mounts configured but with the service
enabled anyway, stopping autofs will always fail.

I will attach a patch.
Comment 2 Jonathan Kamens 2001-08-24 03:22:17 EDT
Created attachment 29347 [details]
Patch to make "autofs stop" behave cleanly when none were started
Comment 3 Nalin Dahyabhai 2001-08-28 19:19:52 EDT
This fix should be integrated into 3.1.7-20 and later.  Thanks!

Note You need to log in before you can comment on or make changes to this bug.